Skip to content

← Actionable
Low, CVSS 2.3amended

parse-server: LiveQuery discloses object data to a subscriber across an ACL read-access change

CVE-2026-57481GHSA-97pr-9hgg-3p8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.1-alpha.13, 8.6.83), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.9.1-alpha.13<= 8.6.82
    Fixed in
    9.9.1-alpha.13, 8.6.83

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-57481: 0.53% estimated exploitation activity in the next 30 days; percentile 44.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Parse Server LiveQuery subscriber can receive object field values they are not authorized to read when a single save changes both an object field and the subscriber's ACL read access to that object. When such a save removes the subscriber's read access, the resulting leave event still carries the post-update object body, disclosing the new field values the subscriber is no longer permitted to read. The symmetric case applies to the enter event: when a save grants read access, the event includes the pre-grant object state the subscriber was not previously permitted to read. The disclosure is bounded to the single object affected by that save and is delivered only to the subscriber whose access changed. Applications that combine content changes with access-control changes in the same save on LiveQuery-enabled classes are affected. Patches Parse Server now verifies the subscriber's authorization for the specific object state included in leave and enter events. For a leave…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-97pr-9hgg-3p8r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-97pr-9hgg-3p8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57481

Advisory: parse-server: LiveQuery discloses object data to a subscriber across an ACL read-access change
IDs: CVE-2026-57481, GHSA-97pr-9hgg-3p8r
Record: https://patchnext.com/advisories/cve-2026-57481 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.1-alpha.13, 8.6.83. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.9.1-alpha.13; <= 8.6.82; fixed in 9.9.1-alpha.13, 8.6.83

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-97pr-9hgg-3p8r (OSV record GHSA-97pr-9hgg-3p8r lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.83 (fixed))
- Verified: https://github.com/advisories/GHSA-97pr-9hgg-3p8r (GitHub-reviewed advisory GHSA-97pr-9hgg-3p8r lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.82)

Commands are suggestions: review each one before running it.

Loading voting…