parse-server: Denial of service via exponential-time processing of deeply nested query operators
CVE-2026-57480GHSA-cgxm-vr2f-6fj8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.1-alpha.12, 8.6.82), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.9.1-alpha.12< 8.6.82
- Fixed in
- 9.9.1-alpha.12, 8.6.82
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cgxm-vr2f-6fj8 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.82 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cgxm-vr2f-6fj8 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.82
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-57480: 0.59% estimated exploitation activity in the next 30 days; percentile 48.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Parse Server is vulnerable to denial of service. A remote attacker can send a single, small query (~1 KB) containing deeply nested query condition operators. Parse Server processes the nested structure with exponential time complexity, which blocks the Node.js event loop and makes the server unresponsive to all clients for the duration of processing. A single request can occupy the event loop for many seconds, and the request is repeatable. The issue affects the REST API and LiveQuery query handling and is reachable in the default configuration. Exploitation requires only the public application identifier; no user authentication is needed. Patches The internal query-traversal helper that previously re-walked nested arrays — causing exponential-time processing of nested $or/$and/$nor operators — was corrected to traverse queries in linear time. Additionally, the optional requestComplexity.queryDepth limit was generalized so that nested logical operators are counted even when…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cgxm-vr2f-6fj8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cgxm-vr2f-6fj8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57480 Advisory: parse-server: Denial of service via exponential-time processing of deeply nested query operators IDs: CVE-2026-57480, GHSA-cgxm-vr2f-6fj8 Record: https://patchnext.com/advisories/cve-2026-57480 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.1-alpha.12, 8.6.82. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.9.1-alpha.12; < 8.6.82; fixed in 9.9.1-alpha.12, 8.6.82 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cgxm-vr2f-6fj8 (OSV record GHSA-cgxm-vr2f-6fj8 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.82 (fixed)) - Verified: https://github.com/advisories/GHSA-cgxm-vr2f-6fj8 (GitHub-reviewed advisory GHSA-cgxm-vr2f-6fj8 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.82) Commands are suggestions: review each one before running it.
Loading voting…