Skip to content

← Actionable
High, CVSS 8.1amended

Vikunja: Scoped API token can mint unrestricted OAuth session credentials

CVE-2026-57458GHSA-v3p6-34mc-hj7v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-57458: 0.33% estimated exploitation activity in the next 30 days; percentile 26.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A scoped API token can bypass its declared permissions by using the OAuth authorization flow to mint normal session credentials. A token limited to: can call /api/v1/oauth/authorize, receive an OAuth authorization code, exchange it at /api/v1/oauth/token, and obtain a normal bearer JWT plus refresh token. The resulting credentials are not restricted by the original API-token permissions. Affected Component Scoped API tokens OAuth authorization flow POST /api/v1/oauth/authorize POST /api/v1/oauth/token Impact A narrowly scoped API token with only oauth.authorize can be converted into normal session credentials for the same user. This bypasses the intended API-token permission boundary. An attacker who obtains or is delegated such a limited token can mint a normal JWT and refresh token, then access routes outside the original token scope. Runtime validation showed that the original scoped token could not access GET /api/v1/user, but the minted OAuth access token could access:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v3p6-34mc-hj7v

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6750

  3. Revision 1 · created ·

    Published from osv record GHSA-v3p6-34mc-hj7v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57458

Advisory: Vikunja: Scoped API token can mint unrestricted OAuth session credentials
IDs: CVE-2026-57458, GHSA-v3p6-34mc-hj7v
Record: https://patchnext.com/advisories/cve-2026-57458 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.vikunja.io/api: affected >= 2.3.0, <= 2.3.0; fixed in 2.4.0

## Suggested inspection (read-only)
- Go code.vikunja.io/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.vikunja.io/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6750 (OSV record GO-2026-6750 lists affected ranges: Go code.vikunja.io/api >=0)
- Verified: https://osv.dev/vulnerability/GHSA-v3p6-34mc-hj7v (OSV record GHSA-v3p6-34mc-hj7v lists affected ranges: Go code.vikunja.io/api >=2.3.0 <2.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v3p6-34mc-hj7v (GitHub-reviewed advisory GHSA-v3p6-34mc-hj7v lists affected ranges: Go code.vikunja.io/api >=2.3.0 <=2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…