Actual Sync Server: CORS Proxy GitHub API Allowlist Prefix Bypass Leaks Private Repositories Through the Server GitHub Token
CVE-2026-57449GHSA-m62c-5q34-f3cf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 26.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 26.6.0
- Fixed in
- 26.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m62c-5q34-f3cf lists affected ranges: npm @actual-app/sync-server >=0 <=26.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m62c-5q34-f3cf lists affected ranges: npm @actual-app/sync-server >=0 <26.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-57449: 0.26% estimated exploitation activity in the next 30 days; percentile 17.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Actual Sync Server's CORS proxy is intended to let authenticated users fetch resources only from repositories listed in the official plugin allowlist. When ACTUALGITHUBTOKEN is configured, the proxy automatically attaches the server's GitHub token to GitHub requests. The GitHub API allowlist check uses a raw startsWith() prefix test for /repos/{owner}/{repo} without requiring a path boundary after the repository name. If an allowlisted public plugin repository is https://github.com/acme/plugin, the proxy also accepts GitHub API URLs such as: Those URLs are outside the allowlisted repository but still pass because their API path starts with /repos/acme/plugin. The proxy then forwards the request with the server's ACTUALGITHUBTOKEN, allowing any authenticated Actual user to read private GitHub resources reachable by that token. Affected Endpoint - GET /cors-proxy?url=... This endpoint is mounted only when: Source: packages/sync-server/src/app.ts:68-70 Details The CORS proxy is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-m62c-5q34-f3cf
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-m62c-5q34-f3cf
- Revision 1 · created ·
Published from ghsa record GHSA-m62c-5q34-f3cf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57449 Advisory: Actual Sync Server: CORS Proxy GitHub API Allowlist Prefix Bypass Leaks Private Repositories Through the Server GitHub Token IDs: CVE-2026-57449, GHSA-m62c-5q34-f3cf Record: https://patchnext.com/advisories/cve-2026-57449 (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 26.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @actual-app/sync-server: affected <= 26.6.0; fixed in 26.7.0 ## Suggested inspection (read-only) - `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @actual-app/sync-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m62c-5q34-f3cf (GitHub-reviewed advisory GHSA-m62c-5q34-f3cf lists affected ranges: npm @actual-app/sync-server >=0 <=26.6.0) - Verified: https://osv.dev/vulnerability/GHSA-m62c-5q34-f3cf (OSV record GHSA-m62c-5q34-f3cf lists affected ranges: npm @actual-app/sync-server >=0 <26.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…