Skip to content

← Actionable
High, CVSS 7.5amended

SCBE-AETHERMOORE Unauthenticated AetherBrowser Ops API Exposes Operator Email Digests

CVE-2026-57443GHSA-q986-4x7x-gx39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (scbe-aethermoore 4.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-57443: 0.74% estimated exploitation activity in the next 30 days; percentile 54.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AetherBrowser API server (scripts/aetherbrowser/apiserver.py) exposes the POST /api/ops/check-email endpoint without any authentication. Any remote attacker can call this endpoint and trigger execution of the emailreader.py subprocess, which connects to configured ProtonMail or Gmail accounts via IMAP and returns email metadata (sender, subject, body snippet) in the JSON response. The server binds to 0.0.0.0:8100 by default with CORS set to alloworigins=[""], making it reachable from any network or browser origin. This constitutes a critical information-disclosure vulnerability. Details scripts/aetherbrowser/apiserver.py registers the following route at line 3008 (report excerpt references line 2987; the actual line is 3008): No Depends() guard, middleware check, or API-key validation is applied. The decorator is a plain @app.post(...), so FastAPI registers the route with zero access control. The server is bound to all interfaces (line 4065/4070): CORS middleware is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q986-4x7x-gx39

  2. Revision 2 · amended ·

    Amended from osv record GHSA-q986-4x7x-gx39

  3. Revision 1 · created ·

    Published from ghsa record GHSA-q986-4x7x-gx39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57443

Advisory: SCBE-AETHERMOORE Unauthenticated AetherBrowser Ops API Exposes Operator Email Digests
IDs: CVE-2026-57443, GHSA-q986-4x7x-gx39
Record: https://patchnext.com/advisories/cve-2026-57443 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: scbe-aethermoore 4.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI scbe-aethermoore: affected >= 4.0.2, < 4.2.1; fixed in 4.2.1

## Suggested inspection (read-only)
- `python -m pip show scbe-aethermoore`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on scbe-aethermoore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q986-4x7x-gx39 (GitHub-reviewed advisory GHSA-q986-4x7x-gx39 lists affected ranges: PyPI scbe-aethermoore >=4.0.2 <4.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-q986-4x7x-gx39 (OSV record GHSA-q986-4x7x-gx39 lists affected ranges: PyPI scbe-aethermoore >=4.0.2 <4.2.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…