Skip to content

← Actionable
Low, CVSS 3.7

Jenkins Active Directory Plugin has an LDAP injection vulnerability

CVE-2026-57288GHSA-gx55-p8g7-p3fh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:active-directory 2.41.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-57288: 0.33% estimated exploitation activity in the next 30 days; percentile 26.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Jenkins Active Directory Plugin 2.41.1 and earlier, the Windows native (ADSI) authentication path does not escape the user name before building the LDAP search filter. This allows unauthenticated attackers to inject LDAP wildcard characters into the user name, enabling them to enumerate directory user and group names, and to authenticate as a matching user when they know that user’s password but not their exact user name. Active Directory Plugin 2.41.2 escapes the user name in the Windows native (ADSI) authentication path before building the LDAP search filter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gx55-p8g7-p3fh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57288

Advisory: Jenkins Active Directory Plugin has an LDAP injection vulnerability
IDs: CVE-2026-57288, GHSA-gx55-p8g7-p3fh
Record: https://patchnext.com/advisories/cve-2026-57288 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:active-directory 2.41.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:active-directory: affected < 2.41.2; fixed in 2.41.2

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:active-directory: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:active-directory.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gx55-p8g7-p3fh (GitHub-reviewed advisory GHSA-gx55-p8g7-p3fh lists affected ranges: Maven org.jenkins-ci.plugins:active-directory >=0 <2.41.2)

Commands are suggestions: review each one before running it.

Loading voting…