Contao: Server-Side Request Forgery (SSRF) via Unvalidated RSS Feed URL in Feed Reader Module
CVE-2026-57232GHSA-87mg-5grr-rhwh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 5.7.9, 5.3.48; contao/core-bundle 5.7.9, 5.3.48), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/contao
- Affected
- >= 5.3.35, < 5.3.48>= 5.4.0, < 5.7.9
- Fixed in
- 5.3.48, 5.7.9
Packagist contao/core-bundle
- Affected
- >= 5.3.35, < 5.3.48>= 5.4.0, < 5.7.9
- Fixed in
- 5.3.48, 5.7.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-87mg-5grr-rhwh lists affected ranges: Packagist contao/contao >=5.3.35 =5.4.0 =5.3.35 =5.4.0 <5.7.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-87mg-5grr-rhwh lists affected ranges: Packagist contao/contao >=5.3.35 =5.4.0 =5.3.35 =5.4.0 <5.7.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-57232: 0.29% estimated exploitation activity in the next 30 days; percentile 21.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Feed Reader front-end module passes RSS feed URLs from its configuration directly to $this-feedIo-read($url) without any scheme validation or private-IP blocklist. A backend user with module-edit permissions can configure an arbitrary URL pointing to internal network services, cloud-provider metadata endpoints, or loopback addresses, causing the server to fetch those resources unconditionally. Confirmed live: the server successfully reaches the internal MySQL database container and its own loopback Apache instance. --- Details In core-bundle/src/Controller/FrontendModule/FeedReaderController.php, the getResponse() function iterates over the configured feed URLs and passes each one directly to the HTTP client with no validation: The DCA field definition for rssfeed in tlmodule.php carries no URL scheme or host validation: The HTTP client is wired as @psr18.httpclient (Symfony HttpClient) with no SSRF protection configured (NoPrivateNetworkHttpClient is not used). ---…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-87mg-5grr-rhwh
- Revision 1 · created ·
Published from osv record GHSA-87mg-5grr-rhwh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57232 Advisory: Contao: Server-Side Request Forgery (SSRF) via Unvalidated RSS Feed URL in Feed Reader Module IDs: CVE-2026-57232, GHSA-87mg-5grr-rhwh Record: https://patchnext.com/advisories/cve-2026-57232 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/contao 5.7.9, 5.3.48; contao/core-bundle 5.7.9, 5.3.48. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/contao: affected >= 5.3.35, < 5.3.48; >= 5.4.0, < 5.7.9; fixed in 5.3.48, 5.7.9 - Packagist contao/core-bundle: affected >= 5.3.35, < 5.3.48; >= 5.4.0, < 5.7.9; fixed in 5.3.48, 5.7.9 ## Suggested inspection (read-only) - Packagist contao/contao: check the installed version with your package manager. - Packagist contao/core-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/contao, contao/core-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-87mg-5grr-rhwh (OSV record GHSA-87mg-5grr-rhwh lists affected ranges: Packagist contao/contao >=5.3.35 =5.4.0 =5.3.35 =5.4.0 <5.7.9 (fixed)) - Verified: https://github.com/advisories/GHSA-87mg-5grr-rhwh (GitHub-reviewed advisory GHSA-87mg-5grr-rhwh lists affected ranges: Packagist contao/contao >=5.3.35 =5.4.0 =5.3.35 =5.4.0 <5.7.9) Commands are suggestions: review each one before running it.
Loading voting…