Skip to content

← Actionable
Unratedamended

Podman: Malformed Image can trick podman run into leaking host environment variables into the container in github.com/containers/libpod

CVE-2026-57231GHSA-4hq8-gpf5-8p68

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/containers/podman/v5

    Affected
    < 5.8.4
    Fixed in
    5.8.4
  • Go github.com/containers/podman/v3

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/containers/libpod

    Affected
    >= 1.8.1
    Fixed in
    no fixed version recorded
  • Go github.com/containers/podman

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/containers/podman/v2

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go go.podman.io/podman/v6

    Affected
    < 6.0.0
    Fixed in
    6.0.0
  • Go github.com/containers/podman/v4

    Affected
    every version
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-57231: 0.44% estimated exploitation activity in the next 30 days; percentile 38.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Podman: Malformed Image can trick podman run into leaking host environment variables into the container in github.com/containers/libpod

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GO-2026-6594

  2. Revision 1 · created ·

    Published from osv record GHSA-4hq8-gpf5-8p68

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57231

Advisory: Podman: Malformed Image can trick podman run into leaking host environment variables into the container in github.com/containers/libpod
IDs: CVE-2026-57231, GHSA-4hq8-gpf5-8p68
Record: https://patchnext.com/advisories/cve-2026-57231 (revision 2, source checked 23 Oct 2026, 22:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/containers/podman/v5 5.8.4; go.podman.io/podman/v6 6.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containers/podman/v5: affected < 5.8.4; fixed in 5.8.4
- Go github.com/containers/podman/v3: affected every version
- Go github.com/containers/libpod: affected >= 1.8.1
- Go github.com/containers/podman: affected every version
- Go github.com/containers/podman/v2: affected every version
- Go go.podman.io/podman/v6: affected < 6.0.0; fixed in 6.0.0
- Go github.com/containers/podman/v4: affected every version

## Suggested inspection (read-only)
- Go github.com/containers/podman/v5: check the installed version with your package manager.
- Go github.com/containers/podman/v3: check the installed version with your package manager.
- Go github.com/containers/libpod: check the installed version with your package manager.
- Go github.com/containers/podman: check the installed version with your package manager.
- Go github.com/containers/podman/v2: check the installed version with your package manager.
- Go go.podman.io/podman/v6: check the installed version with your package manager.
- Go github.com/containers/podman/v4: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containers/podman/v5, github.com/containers/podman/v3, github.com/containers/libpod, github.com/containers/podman, github.com/containers/podman/v2, go.podman.io/podman/v6, github.com/containers/podman/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6594 (OSV record GO-2026-6594 lists affected ranges: Go github.com/containers/libpod >=1.8.1; Go github.com/containers/podman >=0; Go github.com/containers/podman/v2 >=0; Go github.com/containers/podman/v3 >=0; Go github.com/containers/podman/v4 >=0; Go github.com/containers/podman/v5 >=0 =0 <6.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-4hq8-gpf5-8p68 (OSV record GHSA-4hq8-gpf5-8p68 lists affected ranges: Go github.com/containers/podman/v5 >=0 =0 =0 =0 =0 =1.8.1)

Commands are suggestions: review each one before running it.

Loading voting…