Skip to content

← Actionable
Medium, CVSS 4.2amended

social-auth-core has a Session Fixation issue

CVE-2026-57179GHSA-vqg6-3fw6-j9jg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-57179: 0.16% estimated exploitation activity in the next 30 days; percentile 4.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The partial-pipeline resume mechanism accepted partialtoken as a bearer credential without binding it to the browser session that created it. Applications using resumable partial pipeline steps could allow an attacker to start an authentication flow, obtain a valid partial token and verification data, and cause a victim's browser to resume that attacker-controlled flow. This could authenticate the victim's browser as the attacker's account. The issue affects applications using partial pipeline steps such as mailvalidation or custom steps decorated with @partial. Patches The issue has been fixed by binding partial pipeline resumes to the originating browser session. Users should upgrade to a patched version. Fix: https://github.com/python-social-auth/social-core/pull/1816 https://github.com/python-social-auth/social-docs/pull/444 https://github.com/python-social-auth/social-app-django/pull/1009 Workarounds Applications that cannot upgrade immediately should disable resumable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vqg6-3fw6-j9jg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vqg6-3fw6-j9jg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vqg6-3fw6-j9jg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57179

Advisory: social-auth-core has a Session Fixation issue
IDs: CVE-2026-57179, GHSA-vqg6-3fw6-j9jg
Record: https://patchnext.com/advisories/cve-2026-57179 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: social-auth-core 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI social-auth-core: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on social-auth-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqg6-3fw6-j9jg (GitHub-reviewed advisory GHSA-vqg6-3fw6-j9jg lists affected ranges: PyPI social-auth-core >=0 <5.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-vqg6-3fw6-j9jg (OSV record GHSA-vqg6-3fw6-j9jg lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…