Skip to content

← Actionable
High, CVSS 7.4amended

social-auth-core: VK App backend accepts unsigned callback data when auth_key is missing

CVE-2026-57178GHSA-3c93-f73f-qc9h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-57178: 0.16% estimated exploitation activity in the next 30 days; percentile 5.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The vk-app backend accepted VK application callback data without verifying the callback signature when the authkey parameter was omitted. Applications using this backend could treat unsigned attacker-controlled data as a verified VK identity. An attacker could choose callback fields such as viewerid, accesstoken, apiid, and apiresult, potentially allowing authentication as an arbitrary VK user ID. The issue affects only applications using the vk-app backend. Patches The issue has been fixed by requiring authkey to be present and valid before callback data is trusted. Users should upgrade to a patched version. Fix: https://github.com/python-social-auth/social-core/pull/1811 Workarounds Applications that cannot upgrade immediately should disable the vk-app backend by removing socialcore.backends.vk.VKAppOAuth2 from SOCIALAUTHAUTHENTICATIONBACKENDS. There is no complete workaround while continuing to use the vulnerable backend. Credits Reported by @lalalala5678 through GitHub…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3c93-f73f-qc9h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3c93-f73f-qc9h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3c93-f73f-qc9h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57178

Advisory: social-auth-core: VK App backend accepts unsigned callback data when auth_key is missing
IDs: CVE-2026-57178, GHSA-3c93-f73f-qc9h
Record: https://patchnext.com/advisories/cve-2026-57178 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: social-auth-core 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI social-auth-core: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on social-auth-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3c93-f73f-qc9h (GitHub-reviewed advisory GHSA-3c93-f73f-qc9h lists affected ranges: PyPI social-auth-core >=0 <5.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-3c93-f73f-qc9h (OSV record GHSA-3c93-f73f-qc9h lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…