Skip to content

← Actionable
Medium, CVSS 4.3amended

social-auth-core has Login CSRF via Missing State Parameter in LoginRadius Backend

CVE-2026-57177GHSA-x7qq-23vw-7pfg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-57177: 0.11% estimated exploitation activity in the next 30 days; percentile 1.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The LoginRadius backend did not validate OAuth state during the authentication flow. Applications using this backend were vulnerable to login CSRF. An attacker could cause a victim's browser session to complete authentication using an attacker-controlled LoginRadius token, making the victim authenticated as the attacker's LoginRadius identity. The issue affects only applications using the LoginRadius backend. Patches The issue has been fixed by enabling callback state validation for the LoginRadius backend. Users should upgrade to a patched version. Fix: https://github.com/python-social-auth/social-core/pull/1808 Workarounds Applications that cannot upgrade immediately should disable the LoginRadius backend by removing it from SOCIALAUTHAUTHENTICATIONBACKENDS. There is no complete workaround while continuing to use the vulnerable backend. Credits Reported through GitHub private vulnerability reporting by Liyi Zhou, Ziyue Wang, Strick, Maurice, and Chenchen Yu from the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x7qq-23vw-7pfg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x7qq-23vw-7pfg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x7qq-23vw-7pfg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57177

Advisory: social-auth-core has Login CSRF via Missing State Parameter in LoginRadius Backend
IDs: CVE-2026-57177, GHSA-x7qq-23vw-7pfg
Record: https://patchnext.com/advisories/cve-2026-57177 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: social-auth-core 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI social-auth-core: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on social-auth-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x7qq-23vw-7pfg (GitHub-reviewed advisory GHSA-x7qq-23vw-7pfg lists affected ranges: PyPI social-auth-core >=0 <5.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-x7qq-23vw-7pfg (OSV record GHSA-x7qq-23vw-7pfg lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…