social-auth-core Vulnerable to Account Takeover via Identity Binding Flaw in Vend Backend
CVE-2026-57176GHSA-fp7w-m676-w7gc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI social-auth-core
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fp7w-m676-w7gc lists affected ranges: PyPI social-auth-core >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fp7w-m676-w7gc lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-57176: 0.22% estimated exploitation activity in the next 30 days; percentile 12.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Vend OAuth2 backend used only the numeric Vend userid as the social-auth UID. When multiple Vend shops authenticate through the same application, users from different shops with the same internal Vend user ID could collide in the social-auth association table. A user from one shop could then be authenticated as the local account previously associated with the same numeric user ID from another shop. The issue affects applications using the Vend OAuth2 backend with more than one Vend shop. Patches The issue has been fixed by scoping Vend social-auth UIDs by shop. Users should upgrade to a patched version. Fix: https://github.com/python-social-auth/social-core/pull/1795 Workarounds Applications that cannot upgrade immediately should restrict the Vend OAuth2 backend to a single trusted Vend shop. If Vend authentication is not required, the Vend backend can also be disabled by removing it from SOCIALAUTHAUTHENTICATIONBACKENDS. There is no complete workaround while continuing to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fp7w-m676-w7gc
- Revision 2 · amended ·
Amended from osv record GHSA-fp7w-m676-w7gc
- Revision 1 · created ·
Published from ghsa record GHSA-fp7w-m676-w7gc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57176 Advisory: social-auth-core Vulnerable to Account Takeover via Identity Binding Flaw in Vend Backend IDs: CVE-2026-57176, GHSA-fp7w-m676-w7gc Record: https://patchnext.com/advisories/cve-2026-57176 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: social-auth-core 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI social-auth-core: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on social-auth-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fp7w-m676-w7gc (GitHub-reviewed advisory GHSA-fp7w-m676-w7gc lists affected ranges: PyPI social-auth-core >=0 <5.0.0) - Verified: https://osv.dev/vulnerability/GHSA-fp7w-m676-w7gc (OSV record GHSA-fp7w-m676-w7gc lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…