social-auth-core has an Improper Authentication issue
CVE-2026-57175GHSA-vq6g-g6c7-5f2j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI social-auth-core
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vq6g-g6c7-5f2j lists affected ranges: PyPI social-auth-core >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vq6g-g6c7-5f2j lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-57175: 0.23% estimated exploitation activity in the next 30 days; percentile 13.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The SAML backend accepted SAML responses on the Assertion Consumer Service endpoint without verifying that they matched a previously issued AuthnRequest. Applications using SAML account association could allow an attacker with a valid account on a trusted IdP to link the attacker's SAML identity to a logged-in victim's local account. The attacker could then authenticate through SAML and gain access to the victim's account. The issue affects applications using the SAML backend together with authenticated account association. Patches The issue has been fixed by validating SAML responses against stored AuthnRequest IDs. Users should upgrade to a patched version. Fix: https://github.com/python-social-auth/social-core/pull/1794 Workarounds Applications that cannot upgrade immediately should disable SAML account association for already authenticated users. If SAML login is not required, the SAML backend can also be disabled by removing it from SOCIALAUTHAUTHENTICATIONBACKENDS. There…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vq6g-g6c7-5f2j
- Revision 2 · amended ·
Amended from osv record GHSA-vq6g-g6c7-5f2j
- Revision 1 · created ·
Published from ghsa record GHSA-vq6g-g6c7-5f2j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57175 Advisory: social-auth-core has an Improper Authentication issue IDs: CVE-2026-57175, GHSA-vq6g-g6c7-5f2j Record: https://patchnext.com/advisories/cve-2026-57175 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: social-auth-core 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI social-auth-core: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on social-auth-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vq6g-g6c7-5f2j (GitHub-reviewed advisory GHSA-vq6g-g6c7-5f2j lists affected ranges: PyPI social-auth-core >=0 <5.0.0) - Verified: https://osv.dev/vulnerability/GHSA-vq6g-g6c7-5f2j (OSV record GHSA-vq6g-g6c7-5f2j lists affected ranges: PyPI social-auth-core >=0 <5.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…