vLLM: Unauthenticated audio decompression-bomb DoS in /v1/chat/completions
CVE-2026-57173GHSA-hcwq-8wjf-3gcr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- <= 0.23.0
- Fixed in
- 0.24.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hcwq-8wjf-3gcr lists affected ranges: PyPI vllm >=0 <=0.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hcwq-8wjf-3gcr lists affected ranges: PyPI vllm >=0 <0.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-57173: 0.73% estimated exploitation activity in the next 30 days; percentile 54.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The audio decode-duration guard (maxdurations, env VLLMMAXAUDIODECODEDURATIONS, default 600s) that protects against audio decompression-bomb DoS is wired into only the speech-to-text path (/v1/audio/transcriptions). The chat audio path (/v1/chat/completions, inputaudio content parts) calls the same decoder with no limit, so an unauthenticated client can submit a few-KB compressed audio file that expands to multiple GB of float32 PCM at decode time, OOM-killing the worker. This is a distinct sibling of CVE-2026-5497 (video frame-count bomb, VideoMediaIO.loadbase64) and GHSA-pq5c-rjhq-qp7p (image) in the same media subsystem. Verified against main at HEAD d78650c (2026-06-16); applicable to the latest release v0.23.0. Details The guard rejects long audio during decode (before allocation), implemented in vllm/multimodal/media/audio.py: - loadaudiopyav — metadata reject (~82-98) and live sample-count reject (~129-136) - loadaudiosoundfile — frames reject (~165-174) All are gated…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hcwq-8wjf-3gcr
- Revision 2 · amended ·
Amended from osv record GHSA-hcwq-8wjf-3gcr
- Revision 1 · created ·
Published from ghsa record GHSA-hcwq-8wjf-3gcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57173 Advisory: vLLM: Unauthenticated audio decompression-bomb DoS in /v1/chat/completions IDs: CVE-2026-57173, GHSA-hcwq-8wjf-3gcr Record: https://patchnext.com/advisories/cve-2026-57173 (revision 3, source checked 26 Oct 2026, 13:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected <= 0.23.0; fixed in 0.24.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hcwq-8wjf-3gcr (GitHub-reviewed advisory GHSA-hcwq-8wjf-3gcr lists affected ranges: PyPI vllm >=0 <=0.23.0) - Verified: https://osv.dev/vulnerability/GHSA-hcwq-8wjf-3gcr (OSV record GHSA-hcwq-8wjf-3gcr lists affected ranges: PyPI vllm >=0 <0.24.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…