Skip to content

← Actionable
High, CVSS 8.4amended

Trestle is vulnerable to arbitrary file write via path traversal in author generate commands (Incomplete fix of CVE-2026-46345)

CVE-2026-57171GHSA-r4vp-3vw6-r2x5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (compliance-trestle 4.1.0, 3.12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57171: 0.22% estimated exploitation activity in the next 30 days; percentile 12.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

At a glance - Actor: attacker who controls the -o/--output argument to trestle author {catalog,profile,ssp}-generate (e.g. via a CI pipeline that derives the output directory from repository-controlled data) - Primitive: attacker-controlled --output value reaches trestleroot / args.output write sink with only isdirectorynameallowed() (parts[0]-only task-name-collision check), not the PathSecurityValidator.validatelocalpath() guard added by the CVE-2026-46345 fix - Impact: arbitrary-location file write outside the trestle workspace as the process owner (8.4 High; conservative C:N variant 7.7, still High); with --force-overwrite, the attacker-chosen directory is first recursively deleted shutil.rmtree) - Precondition: attacker influences the -o argument in a CI/automation pipeline or multi-tenant trestle workspace running these generate subcommands - Fix: call PathSecurityValidator.validatelocalpath(markdownpath, trestleroot) immediately after building markdownpath in catalog.py,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r4vp-3vw6-r2x5

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r4vp-3vw6-r2x5

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r4vp-3vw6-r2x5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57171

Advisory: Trestle is vulnerable to arbitrary file write via path traversal in author generate commands (Incomplete fix of CVE-2026-46345)
IDs: CVE-2026-57171, GHSA-r4vp-3vw6-r2x5
Record: https://patchnext.com/advisories/cve-2026-57171 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: compliance-trestle 4.1.0, 3.12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI compliance-trestle: affected < 3.12.4; >= 4.0.0, < 4.1.0; fixed in 3.12.4, 4.1.0

## Suggested inspection (read-only)
- `python -m pip show compliance-trestle`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on compliance-trestle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r4vp-3vw6-r2x5 (GitHub-reviewed advisory GHSA-r4vp-3vw6-r2x5 lists affected ranges: PyPI compliance-trestle >=0 =4.0.0 <4.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-r4vp-3vw6-r2x5 (OSV record GHSA-r4vp-3vw6-r2x5 lists affected ranges: PyPI compliance-trestle >=0 =4.0.0 <4.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…