Skip to content

← Actionable
High, CVSS 7.8amended

Trestle SSTI in Jinja2 include tags allows arbitrary code execution (Incomplete fix of CVE-2026-46439)

CVE-2026-57170GHSA-mr95-65j8-9mxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (compliance-trestle 4.1.0, 3.12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57170: 0.24% estimated exploitation activity in the next 30 days; percentile 14.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Reporter: Cavan Loughran, Celvex Group Inc. Summary ------- The fix for CVE-2026-46439 (3.12.2 / 4.0.3) removed the recursive re-render loop in trestle/core/commands/author/jinja.py rendertemplate, but the custom include tags in trestle/core/jinja/tags.py (MDSectionInclude, MDCleanInclude) still re-parse the CONTENT of an included markdown file as a Jinja2 template via Parser(self.environment, <file text).parse() in a plain (non-sandboxed) jinja2.Environment. Because the trestle markdown writers (sspio.py SSPMarkdownWriter, docscontrolwriter.py DocsControlWriter) write OSCAL prose / component-description fields verbatim (the {{ - [ neutralization is applied to parameter tables only), attacker-controlled OSCAL data that flows into an included markdown file is interpreted as template code and can achieve arbitrary code execution on the runner. This is the same trust boundary and impact as CVE-2026-46439 via a sink the fix did not cover. Affected versions ----------------- 4.0.3 and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mr95-65j8-9mxp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-mr95-65j8-9mxp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-mr95-65j8-9mxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57170

Advisory: Trestle SSTI in Jinja2 include tags allows arbitrary code execution (Incomplete fix of CVE-2026-46439)
IDs: CVE-2026-57170, GHSA-mr95-65j8-9mxp
Record: https://patchnext.com/advisories/cve-2026-57170 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: compliance-trestle 4.1.0, 3.12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI compliance-trestle: affected < 3.12.4; >= 4.0.0, < 4.1.0; fixed in 3.12.4, 4.1.0

## Suggested inspection (read-only)
- `python -m pip show compliance-trestle`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on compliance-trestle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mr95-65j8-9mxp (GitHub-reviewed advisory GHSA-mr95-65j8-9mxp lists affected ranges: PyPI compliance-trestle >=0 =4.0.0 <4.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-mr95-65j8-9mxp (OSV record GHSA-mr95-65j8-9mxp lists affected ranges: PyPI compliance-trestle >=0 =4.0.0 <4.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…