praisonai-platform 0.1.4 still boots on the hardcoded JWT secret dev-secret-change-me (default-open production guard)
CVE-2026-57148GHSA-f38v-77qj-h4jq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai-platform 0.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai-platform
- Affected
- <= 0.1.4
- Fixed in
- 0.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f38v-77qj-h4jq lists affected ranges: PyPI praisonai-platform >=0 <=0.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f38v-77qj-h4jq lists affected ranges: PyPI praisonai-platform >=0 <0.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-57148: 0.64% estimated exploitation activity in the next 30 days; percentile 50.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
- Affected: praisonai-platform (PyPI) <= 0.1.4 — including 0.1.4, the version GHSA-3qg8-5g3r-79v5 declares as the patch; main HEAD 8acf77c531e624c46d3d61dcae37e9942e90972c is also affected. File src/praisonai-platform/praisonaiplatform/services/authservice.py - CWE: CWE-1188 (Insecure Default Initialization) + CWE-798 (Use of Hard-coded Credentials) - CWE-287 (Improper Authentication) Overview GHSA-3qg8-5g3r-79v5 (Critical) reported that praisonai-platform's JWT signing secret defaulted to the hardcoded literal "dev-secret-change-me", and that the production guard meant to prevent this was default-open (it only fired when PLATFORMENV != "dev", but PLATFORMENV defaults to "dev"). That advisory declares the issue patched in = 0.1.4. It is not. The shipped praisonai-platform==0.1.4 (and current main) still resolves the signing key to "dev-secret-change-me" in any deployment that does not explicitly set PLATFORMJWTSECRET, because the 0.1.4 change merely duplicated the same default-open…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f38v-77qj-h4jq
- Revision 2 · amended ·
Amended from osv record GHSA-f38v-77qj-h4jq
- Revision 1 · created ·
Published from ghsa record GHSA-f38v-77qj-h4jq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57148 Advisory: praisonai-platform 0.1.4 still boots on the hardcoded JWT secret dev-secret-change-me (default-open production guard) IDs: CVE-2026-57148, GHSA-f38v-77qj-h4jq Record: https://patchnext.com/advisories/cve-2026-57148 (revision 3, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai-platform 0.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai-platform: affected <= 0.1.4; fixed in 0.1.6 ## Suggested inspection (read-only) - `python -m pip show praisonai-platform`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai-platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f38v-77qj-h4jq (GitHub-reviewed advisory GHSA-f38v-77qj-h4jq lists affected ranges: PyPI praisonai-platform >=0 <=0.1.4) - Verified: https://osv.dev/vulnerability/GHSA-f38v-77qj-h4jq (OSV record GHSA-f38v-77qj-h4jq lists affected ranges: PyPI praisonai-platform >=0 <0.1.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…