praisonai-platform: default JWT signing secret 'dev-secret-change-me' enables token forgery
CVE-2026-57147GHSA-cwj8-7gp2-ggcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai-platform 0.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai-platform
- Affected
- <= 0.1.4
- Fixed in
- 0.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cwj8-7gp2-ggcw lists affected ranges: PyPI praisonai-platform >=0 <=0.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cwj8-7gp2-ggcw lists affected ranges: PyPI praisonai-platform >=0 <0.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-57147: 0.77% estimated exploitation activity in the next 30 days; percentile 55.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
praisonai-platform: default JWT signing secret dev-secret-change-me Researcher: Kai Aizen — SnailSploit (@SnailSploit), Adversarial & Offensive Security Research Target: https://github.com/MervinPraison/PraisonAI --- Package: praisonai-platform on PyPI Latest version (and version tested): 0.1.4, current as of 2026-06-01. File: praisonaiplatform/services/authservice.py (sha256 cc29d43c5412da2c73c818859b8d8b146587842999b777336017ab9d9e509258). Weakness: CWE-798 Use of Hardcoded Credentials + CWE-1188 Insecure Default Initialization of Resource. --- TL;DR praisonaiplatform/services/authservice.py lines 25-37: The guard at line 33 is meant to catch the "deployed to production with the default secret" failure mode. But it only fires when both: - the operator left PLATFORMJWTSECRET unset (so JWTSECRET is the default literal), and - the operator explicitly set PLATFORMENV to something other than "dev". If the operator left both env vars unset — the most common mis-deploy — PLATFORMENV falls…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cwj8-7gp2-ggcw
- Revision 2 · amended ·
Amended from osv record GHSA-cwj8-7gp2-ggcw
- Revision 1 · created ·
Published from ghsa record GHSA-cwj8-7gp2-ggcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57147 Advisory: praisonai-platform: default JWT signing secret 'dev-secret-change-me' enables token forgery IDs: CVE-2026-57147, GHSA-cwj8-7gp2-ggcw Record: https://patchnext.com/advisories/cve-2026-57147 (revision 3, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai-platform 0.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai-platform: affected <= 0.1.4; fixed in 0.1.6 ## Suggested inspection (read-only) - `python -m pip show praisonai-platform`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai-platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cwj8-7gp2-ggcw (GitHub-reviewed advisory GHSA-cwj8-7gp2-ggcw lists affected ranges: PyPI praisonai-platform >=0 <=0.1.4) - Verified: https://osv.dev/vulnerability/GHSA-cwj8-7gp2-ggcw (OSV record GHSA-cwj8-7gp2-ggcw lists affected ranges: PyPI praisonai-platform >=0 <0.1.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…