Skip to content

← Actionable
High, CVSS 7.8amended

PraisonAI recipe workflow policy can be bypassed by declaring and YAML-approving dangerous tools outside TEMPLATE.yaml

CVE-2026-57142GHSA-7qw2-w5rc-37x2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.61), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    >= 4.5.87, < 4.6.61
    Fixed in
    4.6.61

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57142: 0.24% estimated exploitation activity in the next 30 days; percentile 15.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PraisonAI recipe execution has a dangerous-tool policy that is supposed to block default-denied tools unless the caller explicitly passes allowdangeroustools=True. That policy only checks tools declared in TEMPLATE.yaml requires.tools. For steps-based recipes, the actual execution path loads workflow.yaml with YAMLWorkflowParser. That parser resolves agent-level tools: declarations and preserves top-level approve:. Workflow.start() then installs those YAML-approved tools into the approval context. As a result, an untrusted recipe can omit executecommand from TEMPLATE.yaml requires.tools, declare it in workflow.yaml agents..tools, and add top-level approve: [executecommand]. The caller did not set allowdangeroustools=True, but the recipe policy allows the recipe and the workflow approval path self-approves the critical shell tool. The local PoV uses a harmless printf canary and explicitly unsets PRAISONAIAUTOAPPROVE. Technical Details recipe.run() checks the recipe policy…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7qw2-w5rc-37x2

  2. Revision 1 · created ·

    Published from osv record GHSA-7qw2-w5rc-37x2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57142

Advisory: PraisonAI recipe workflow policy can be bypassed by declaring and YAML-approving dangerous tools outside TEMPLATE.yaml
IDs: CVE-2026-57142, GHSA-7qw2-w5rc-37x2
Record: https://patchnext.com/advisories/cve-2026-57142 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.61. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected >= 4.5.87, < 4.6.61; fixed in 4.6.61

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7qw2-w5rc-37x2 (OSV record GHSA-7qw2-w5rc-37x2 lists affected ranges: PyPI praisonai >=4.5.87 <4.6.61 (fixed))
- Verified: https://github.com/advisories/GHSA-7qw2-w5rc-37x2 (GitHub-reviewed advisory GHSA-7qw2-w5rc-37x2 lists affected ranges: PyPI praisonai >=4.5.87 <4.6.61)

Commands are suggestions: review each one before running it.

Loading voting…