Skip to content

← Actionable
Critical, CVSS 9.8amended

PraisonAI: Remote Code Execution via Sandbox Escape in codeMode Tool

CVE-2026-57141GHSA-p69m-4f92-2v84

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57141: 0.74% estimated exploitation activity in the next 30 days; percentile 54.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The codeMode tool in src/praisonai-ts/src/tools/builtins/code-mode.ts uses new Function() with a with(sandbox) pattern to execute LLM-generated code. The blocklist-based "sandbox" can be trivially bypassed via Function('return this')() to recover the global object, followed by global.require() with string concatenation to evade the blocklist regex. This allows full arbitrary code execution on the host system. This affects all deployments where the code-mode tool is enabled for agents. Details Vulnerable code (lines 187–191): The code parameter comes from LLM tool call arguments (the execute method at line 104). Before execution, a regex-based blocklist is applied (lines 108–136): Three fundamental weaknesses: 1. with(sandbox) does not provide isolation. The with statement in JavaScript adds an object to the scope chain but does NOT prevent accessing the global object. The sandbox object sets process: undefined and require: undefined, but these are recovered via the global…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p69m-4f92-2v84

  2. Revision 2 · amended ·

    Amended from osv record GHSA-p69m-4f92-2v84

  3. Revision 1 · created ·

    Published from ghsa record GHSA-p69m-4f92-2v84

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57141

Advisory: PraisonAI: Remote Code Execution via Sandbox Escape in `codeMode` Tool
IDs: CVE-2026-57141, GHSA-p69m-4f92-2v84
Record: https://patchnext.com/advisories/cve-2026-57141 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm praisonai: affected <= 1.7.1; fixed in 1.7.2

## Suggested inspection (read-only)
- `npm ls praisonai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p69m-4f92-2v84 (GitHub-reviewed advisory GHSA-p69m-4f92-2v84 lists affected ranges: npm praisonai >=0 <=1.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-p69m-4f92-2v84 (OSV record GHSA-p69m-4f92-2v84 lists affected ranges: npm praisonai >=0 <1.7.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…