Skip to content

← Actionable
Critical, CVSS 9.4amended

npm PraisonAI AgentOS exposes unauthenticated agent listing and invocation

CVE-2026-57140GHSA-9752-mhqh-h34f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm praisonai

    Affected
    >= 1.6.0, <= 1.7.1
    Fixed in
    1.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-57140: 0.64% estimated exploitation activity in the next 30 days; percentile 50.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The published npm package praisonai ships a TypeScript AgentOS HTTP server that defaults to host: "0.0.0.0" and registers sensitive agent routes without any authentication or authorization middleware. When a developer starts AgentOS, a network attacker who can reach the service can: - read configured agent names, roles, and the first 100 characters of each agent's instructions through GET /api/agents; and - invoke the selected agent through POST /api/chat without credentials. This is distinct from the existing Python/PyPI AgentOS and API-server advisories. The affected package here is npm:praisonai; the current published npm package is 1.7.1, and the same TypeScript source is still present in refreshed origin/main at v4.6.58. Technical Details AgentOSConfig exposes host, CORS, and API-prefix settings but no authentication token, auth mode, or authorization callback. Relevant current-head source: AgentOS.createApp() registers JSON parsing and CORS handling, then immediately…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9752-mhqh-h34f

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9752-mhqh-h34f

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9752-mhqh-h34f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57140

Advisory: npm PraisonAI AgentOS exposes unauthenticated agent listing and invocation
IDs: CVE-2026-57140, GHSA-9752-mhqh-h34f
Record: https://patchnext.com/advisories/cve-2026-57140 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm praisonai: affected >= 1.6.0, <= 1.7.1; fixed in 1.7.2

## Suggested inspection (read-only)
- `npm ls praisonai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9752-mhqh-h34f (GitHub-reviewed advisory GHSA-9752-mhqh-h34f lists affected ranges: npm praisonai >=1.6.0 <=1.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-9752-mhqh-h34f (OSV record GHSA-9752-mhqh-h34f lists affected ranges: npm praisonai >=1.6.0 <1.7.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…