Skip to content

← Actionable
Critical, CVSS 9.8amended

npm PraisonAI MCPServer exposes unauthenticated HTTP tools/call

CVE-2026-57139GHSA-j4f3-55x4-r6q2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm praisonai

    Affected
    >= 1.5.0, <= 1.7.1
    Fixed in
    1.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57139: 0.75% estimated exploitation activity in the next 30 days; percentile 55.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The published npm package praisonai exports a TypeScript MCPServer that can expose tools, resources, and prompts over an HTTP JSON-RPC transport with: The HTTP transport has no authentication or authorization path. MCPServerConfig does not expose an auth/security setting, startHttp() ignores the Authorization header, and every POST request is parsed and forwarded directly to handleRequest(). That request handler dispatches sensitive MCP methods such as tools/call, resources/read, and prompts/get. The implementation also calls this.httpServer.listen(port) without a host argument. In Node.js this binds to the unspecified address; the local PoV observed { address: "::", family: "IPv6" }, making the service reachable on all interfaces on systems where the port is exposed. This lets any network client that can reach the HTTP port list tools and invoke registered server-side tools without credentials. Supplying Authorization: Bearer invalid makes no difference. Technical Details…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j4f3-55x4-r6q2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-j4f3-55x4-r6q2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-j4f3-55x4-r6q2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57139

Advisory: npm PraisonAI MCPServer exposes unauthenticated HTTP tools/call
IDs: CVE-2026-57139, GHSA-j4f3-55x4-r6q2
Record: https://patchnext.com/advisories/cve-2026-57139 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm praisonai: affected >= 1.5.0, <= 1.7.1; fixed in 1.7.2

## Suggested inspection (read-only)
- `npm ls praisonai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j4f3-55x4-r6q2 (GitHub-reviewed advisory GHSA-j4f3-55x4-r6q2 lists affected ranges: npm praisonai >=1.5.0 <=1.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-j4f3-55x4-r6q2 (OSV record GHSA-j4f3-55x4-r6q2 lists affected ranges: npm praisonai >=1.5.0 <1.7.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…