Skip to content

← Actionable
Critical, CVSS 9.9amended

npm PraisonAI codeMode sandbox escape via Function constructor

CVE-2026-57138GHSA-vmmj-pfw7-fjwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm praisonai

    Affected
    >= 1.4.0, <= 1.7.1
    Fixed in
    1.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-57138: 0.73% estimated exploitation activity in the next 30 days; percentile 54.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The published npm package praisonai exports a TypeScript built-in tool named codeMode. The package describes this tool as executing code in a sandboxed environment, marks its capability as sandbox: true, and registers it through the public tools facade. The implementation does not create an isolation boundary. It applies a small regular-expression blocklist, sets process and require to undefined inside a plain JavaScript object, and then executes attacker-controlled code with the host process new Function constructor: Because this runs in the host V8 context, code inside codeMode can use the JavaScript prototype chain to recover the real Function constructor: From a normal CommonJS application script, the recovered process object exposes process.mainModule.require. That bypasses the explicit require('fs') and require('childprocess') controls and allows host filesystem access and subprocess execution from code that was supposed to be sandboxed. Technical Details Current-head…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vmmj-pfw7-fjwp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vmmj-pfw7-fjwp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vmmj-pfw7-fjwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57138

Advisory: npm PraisonAI codeMode sandbox escape via Function constructor
IDs: CVE-2026-57138, GHSA-vmmj-pfw7-fjwp
Record: https://patchnext.com/advisories/cve-2026-57138 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm praisonai: affected >= 1.4.0, <= 1.7.1; fixed in 1.7.2

## Suggested inspection (read-only)
- `npm ls praisonai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vmmj-pfw7-fjwp (GitHub-reviewed advisory GHSA-vmmj-pfw7-fjwp lists affected ranges: npm praisonai >=1.4.0 <=1.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-vmmj-pfw7-fjwp (OSV record GHSA-vmmj-pfw7-fjwp lists affected ranges: npm praisonai >=1.4.0 <1.7.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…