npm PraisonAI MCPSecurity Basic/OAuth authentication policies accept invalid credentials without validation
CVE-2026-57134GHSA-4qq2-2j2x-x62c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm praisonai
- Affected
- >= 1.5.1, <= 1.7.1
- Fixed in
- 1.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4qq2-2j2x-x62c lists affected ranges: npm praisonai >=1.5.1 <1.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4qq2-2j2x-x62c lists affected ranges: npm praisonai >=1.5.1 <=1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-57134: 0.41% estimated exploitation activity in the next 30 days; percentile 35.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The published npm package praisonai exports an MCPSecurity helper described in source as: Its AuthMethod type advertises five authentication methods: The authentication-policy evaluator, however, only validates credentials for api-key and bearer: For basic and oauth, any non-empty Authorization header skips the supplied validate callback and returns allowed. A local PoV configures auth.validate to always return false; invalid api-key and bearer credentials are rejected, while invalid basic and oauth credentials are accepted without calling the validator. This is a protection-mechanism failure in the exported npm MCP security helper. It is distinct from the separate issue that the npm MCPServer HTTP transport does not enforce authentication by default. Technical Details SecurityPolicy.auth accepts both a method and a validator: extractToken() parses both Bearer and Basic headers: But evaluatePolicy() only calls policy.auth.validate() for two methods: There is no validation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4qq2-2j2x-x62c
- Revision 1 · created ·
Published from osv record GHSA-4qq2-2j2x-x62c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57134 Advisory: npm PraisonAI MCPSecurity Basic/OAuth authentication policies accept invalid credentials without validation IDs: CVE-2026-57134, GHSA-4qq2-2j2x-x62c Record: https://patchnext.com/advisories/cve-2026-57134 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai 1.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm praisonai: affected >= 1.5.1, <= 1.7.1; fixed in 1.7.2 ## Suggested inspection (read-only) - `npm ls praisonai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4qq2-2j2x-x62c (OSV record GHSA-4qq2-2j2x-x62c lists affected ranges: npm praisonai >=1.5.1 <1.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4qq2-2j2x-x62c (GitHub-reviewed advisory GHSA-4qq2-2j2x-x62c lists affected ranges: npm praisonai >=1.5.1 <=1.7.1) Commands are suggestions: review each one before running it.
Loading voting…