Skip to content

← Actionable
Critical, CVSS 9.8amended

praisonai: recipe serve auth middleware silently disables itself when no secret is set

CVE-2026-57127GHSA-j4hj-7hfh-g2f4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.59), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.48
    Fixed in
    4.6.59

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57127: 0.90% estimated exploitation activity in the next 30 days; percentile 59.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

praisonai: recipe serve authentication middleware silently disables itself when no secret is set Researcher: Kai Aizen — SnailSploit (@SnailSploit), Adversarial & Offensive Security Research Target: https://github.com/MervinPraison/PraisonAI --- Package: praisonai on PyPI Version tested: 4.6.48. File: praisonai/recipe/serve.py (sha256 491bf8f29e399418260810ba4bf0f6802c6e4aa675628e2be68a9726c15d9b23). --- TL;DR praisonai/recipe/serve.py:312-410 defines two auth middlewares (APIKeyAuthMiddleware, JWTAuthMiddleware). Both contain the same "fail open when the secret is unset" branch at the top of their dispatch: The realistic mis-deploy: 1. operator sets auth: api-key (or auth: jwt) in their recipe YAML, expecting that line alone to enable auth, 2. operator does not set the corresponding apikey: / jwtsecret: value in the same YAML, AND 3. operator does not export PRAISONAIAPIKEY / PRAISONAIJWTSECRET in the environment. The middleware silently treats every request as authenticated and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j4hj-7hfh-g2f4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-j4hj-7hfh-g2f4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-j4hj-7hfh-g2f4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57127

Advisory: praisonai: recipe serve auth middleware silently disables itself when no secret is set
IDs: CVE-2026-57127, GHSA-j4hj-7hfh-g2f4
Record: https://patchnext.com/advisories/cve-2026-57127 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.59. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.48; fixed in 4.6.59

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j4hj-7hfh-g2f4 (GitHub-reviewed advisory GHSA-j4hj-7hfh-g2f4 lists affected ranges: PyPI praisonai >=0 <=4.6.48)
- Verified: https://osv.dev/vulnerability/GHSA-j4hj-7hfh-g2f4 (OSV record GHSA-j4hj-7hfh-g2f4 lists affected ranges: PyPI praisonai >=0 <4.6.59 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…