Skip to content

← Actionable
Critical, CVSS 9.8amended

PraisonAI: Missing Authentication for Critical Function and Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in praisonai

CVE-2026-57124GHSA-p75f-6fp4-p57w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.59), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.48
    Fixed in
    4.6.59

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57124: 1.03% estimated exploitation activity in the next 30 days; percentile 63.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthenticated PraisonAI UI MCP connect endpoint executes attacker-chosen local commands Summary PraisonAI v4.6.48 exposes the PraisonAIUI MCP client management API through the default UI host apps without authentication. A remote unauthenticated client can send POST /api/mcp/connect with a command and args field. The endpoint passes those values into the MCP stdio client, which starts the attacker-selected local process as the PraisonAI UI service user. The issue is reachable through PraisonAI's hosted UI integration (praisonai ui, praisonai ui agents, praisonai claw, and any app using praisonai.integration.hostapp.createhostapp() / buildhostapp()). praisonai ui and related Typer UI commands bind to 0.0.0.0 by default. Affected Versions Confirmed affected: - praisonai v4.6.48 - Commit tested: d5f1114aaf1a2e9f121a6e66b929149ca2201f1d - Tag tested: v4.6.48 - Pinned UI dependency: aiui==0.3.121 from src/praisonai/uv.lock Likely affected: - Any PraisonAI release that exposes aiui /…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p75f-6fp4-p57w

  2. Revision 2 · amended ·

    Amended from osv record GHSA-p75f-6fp4-p57w

  3. Revision 1 · created ·

    Published from ghsa record GHSA-p75f-6fp4-p57w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57124

Advisory: PraisonAI: Missing Authentication for Critical Function and Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in praisonai
IDs: CVE-2026-57124, GHSA-p75f-6fp4-p57w
Record: https://patchnext.com/advisories/cve-2026-57124 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.59. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.48; fixed in 4.6.59

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p75f-6fp4-p57w (GitHub-reviewed advisory GHSA-p75f-6fp4-p57w lists affected ranges: PyPI praisonai >=0 <=4.6.48)
- Verified: https://osv.dev/vulnerability/GHSA-p75f-6fp4-p57w (OSV record GHSA-p75f-6fp4-p57w lists affected ranges: PyPI praisonai >=0 <4.6.59 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…