Skip to content

← Actionable
High, CVSS 8.8amended

PraisonAI: Compute-bridged file tools allow shell command injection

CVE-2026-57117GHSA-w6h2-fr4q-xvxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.59), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    >= 4.6.10, <= 4.6.58
    Fixed in
    4.6.59

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-57117: 0.58% estimated exploitation activity in the next 30 days; percentile 47.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Compute-bridged file tools allow shell command injection Summary LocalManagedAgent / SandboxedAgent compute bridging wraps readfile, listfiles, and writefile when a compute provider is attached. The bridge converts those file operations into shell command strings using raw path arguments, then sends those strings to shell-backed compute providers. An attacker who can influence a file-tool path argument can break out of the quoted path and execute arbitrary shell commands in the compute environment. With compute="local", commands execute through the local subprocess compute provider on the host. With Docker, commands execute in the container. Affected Product - Repository: MervinPraison/PraisonAI - Package: praisonai - Component: src/praisonai/praisonai/integrations/managedlocal.py - Confirmed affected: - v4.6.10 - v4.6.56 - v4.6.57 - current main at 2f9677abb2ea68eab864ee8b6a828fd0141612e1 - Confirmed not affected: - v4.6.9 - v4.6.1 - v4.5.149 - Suggested affected range: = 4.6.10, <=…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w6h2-fr4q-xvxv

  2. Revision 1 · created ·

    Published from osv record GHSA-w6h2-fr4q-xvxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57117

Advisory: PraisonAI: Compute-bridged file tools allow shell command injection
IDs: CVE-2026-57117, GHSA-w6h2-fr4q-xvxv
Record: https://patchnext.com/advisories/cve-2026-57117 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.59. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected >= 4.6.10, <= 4.6.58; fixed in 4.6.59

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w6h2-fr4q-xvxv (OSV record GHSA-w6h2-fr4q-xvxv lists affected ranges: PyPI praisonai >=4.6.10 <4.6.59 (fixed))
- Verified: https://github.com/advisories/GHSA-w6h2-fr4q-xvxv (GitHub-reviewed advisory GHSA-w6h2-fr4q-xvxv lists affected ranges: PyPI praisonai >=4.6.10 <=4.6.58)

Commands are suggestions: review each one before running it.

Loading voting…