PraisonAI ToolsMCPServer legacy SSE transport accepts attacker Host/Origin and exposes registered tools
CVE-2026-57112GHSA-vmf9-xx9w-86wx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.6.59; praisonai 4.6.59), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonaiagents
- Affected
- >= 0.6.0, <= 1.6.58
- Fixed in
- 1.6.59
PyPI praisonai
- Affected
- >= 3.10.0, <= 4.6.58
- Fixed in
- 4.6.59
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmf9-xx9w-86wx lists affected ranges: PyPI praisonaiagents >=0.6.0 =3.10.0 <4.6.59 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmf9-xx9w-86wx lists affected ranges: PyPI praisonaiagents >=0.6.0 =3.10.0 <=4.6.58
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-57112: 0.22% estimated exploitation activity in the next 30 days; percentile 13.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PraisonAI ToolsMCPServer legacy SSE transport accepts attacker Host/Origin and exposes registered tools Summary praisonaiagents.mcp.ToolsMCPServer.runsse() builds a Starlette MCP HTTP+SSE server around mcp.server.sse.SseServerTransport. The server exposes /sse and /messages/, but it does not validate Origin, does not validate Host, and does not require any authentication. This is reachable through supported PraisonAI code paths that wrap configured MCP server tools and re-expose them over legacy SSE: - praisonai mcp run <name --transport sse - praisonai serve mcp --name <name --transport sse - direct use of ToolsMCPServer(...).runsse(...) or launchtoolsmcpserver(..., transport="sse") A malicious website can use DNS rebinding against a local or internal PraisonAI SSE MCP server and send requests with attacker-controlled Host and Origin headers. The local PoV binds only to 127.0.0.1, sends an attacker Host and Origin, lists the registered tool, and invokes it successfully. The same…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vmf9-xx9w-86wx
- Revision 1 · created ·
Published from osv record GHSA-vmf9-xx9w-86wx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57112 Advisory: PraisonAI ToolsMCPServer legacy SSE transport accepts attacker Host/Origin and exposes registered tools IDs: CVE-2026-57112, GHSA-vmf9-xx9w-86wx Record: https://patchnext.com/advisories/cve-2026-57112 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.6.59; praisonai 4.6.59. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonaiagents: affected >= 0.6.0, <= 1.6.58; fixed in 1.6.59 - PyPI praisonai: affected >= 3.10.0, <= 4.6.58; fixed in 4.6.59 ## Suggested inspection (read-only) - `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active. - `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonaiagents, praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vmf9-xx9w-86wx (OSV record GHSA-vmf9-xx9w-86wx lists affected ranges: PyPI praisonaiagents >=0.6.0 =3.10.0 <4.6.59 (fixed)) - Verified: https://github.com/advisories/GHSA-vmf9-xx9w-86wx (GitHub-reviewed advisory GHSA-vmf9-xx9w-86wx lists affected ranges: PyPI praisonaiagents >=0.6.0 =3.10.0 <=4.6.58) Commands are suggestions: review each one before running it.
Loading voting…