Add recursion depth guard during decode in encoding/xml
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (stdlib 1.27.0-rc.3, 1.26.6, 1.25.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go stdlib
- Affected
- < 1.25.13>= 1.26.0-0, < 1.26.6>= 1.27.0-0, < 1.27.0-rc.3
- Fixed in
- 1.25.13, 1.26.6, 1.27.0-rc.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6088 lists affected ranges: Go stdlib >=0 =1.26.0-0 =1.27.0-0 <1.27.0-rc.3 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-56859: 0.57% estimated exploitation activity in the next 30 days; percentile 47.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Previously, DecodeElement would reset the depth counter causing it to never fire; this could lead to stack exhaustion.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GO-2026-6088
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56859 Advisory: Add recursion depth guard during decode in encoding/xml IDs: CVE-2026-56859 Record: https://patchnext.com/advisories/cve-2026-56859 (revision 1, source checked 23 Oct 2026, 22:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: stdlib 1.27.0-rc.3, 1.26.6, 1.25.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go stdlib: affected < 1.25.13; >= 1.26.0-0, < 1.26.6; >= 1.27.0-0, < 1.27.0-rc.3; fixed in 1.25.13, 1.26.6, 1.27.0-rc.3 ## Suggested inspection (read-only) - Go stdlib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on stdlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6088 (OSV record GO-2026-6088 lists affected ranges: Go stdlib >=0 =1.26.0-0 =1.27.0-0 <1.27.0-rc.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…