Skip to content

← Actionable
High, CVSS 7.8amended

PraisonAI recipe.run_stream skips dangerous-tool policy enforcement

CVE-2026-56838GHSA-v847-hxxw-3pxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.59), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    >= 4.5.87, <= 4.6.58
    Fixed in
    4.6.59

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-56838: 0.15% estimated exploitation activity in the next 30 days; percentile 3.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PraisonAI recipe.runstream() skips dangerous-tool policy enforcement Summary PraisonAI recipe execution blocks default-denied dangerous tools unless the caller explicitly passes allowdangeroustools=True. The normal recipe.run() path enforces this with checktoolpolicy(). The streaming path, recipe.runstream(), loads the same recipe, checks dependencies, and then calls executerecipe() without running the dangerous-tool policy check. As a result, a recipe that honestly declares executecommand in TEMPLATE.yaml requires.tools is denied by recipe.run(), but reaches the execution engine through recipe.runstream() with allowdangeroustools=False. The local PoV uses a harmless printf canary, explicitly unsets PRAISONAIAUTOAPPROVE, and avoids network access. Affected Product - Repository: MervinPraison/PraisonAI - Package: praisonai - Components: - src/praisonai/praisonai/recipe/core.py - src/praisonai/praisonai/recipe/serve.py - src/praisonai/praisonai/cli/features/recipe.py -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v847-hxxw-3pxg

  2. Revision 1 · created ·

    Published from osv record GHSA-v847-hxxw-3pxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56838

Advisory: PraisonAI recipe.run_stream skips dangerous-tool policy enforcement
IDs: CVE-2026-56838, GHSA-v847-hxxw-3pxg
Record: https://patchnext.com/advisories/cve-2026-56838 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.59. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected >= 4.5.87, <= 4.6.58; fixed in 4.6.59

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v847-hxxw-3pxg (OSV record GHSA-v847-hxxw-3pxg lists affected ranges: PyPI praisonai >=4.5.87 <4.6.59 (fixed))
- Verified: https://github.com/advisories/GHSA-v847-hxxw-3pxg (GitHub-reviewed advisory GHSA-v847-hxxw-3pxg lists affected ranges: PyPI praisonai >=4.5.87 <=4.6.58)

Commands are suggestions: review each one before running it.

Loading voting…