Skip to content

← Actionable
High, CVSS 7.5amended

PraisonAI Dynamic Context history and terminal tools read files outside configured storage via path traversal

CVE-2026-56833GHSA-22cj-m4wf-fv2c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.59), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    >= 3.8.1, <= 4.6.58
    Fixed in
    4.6.59

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-56833: 0.46% estimated exploitation activity in the next 30 days; percentile 39.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PraisonAI Dynamic Context history and terminal tools read files outside configured storage via path traversal Summary PraisonAI's Dynamic Context module provides filesystem-backed history and terminal-log storage. The SDK reference describes the module as providing: - artifact storage for tool outputs, history, and terminal logs; - history persistence with search; and - terminal session logging. The module also exports agent-callable tool factories: - createhistorytools() returns historysearch, historytail, and historyget. - createterminaltools() returns terminaltail, terminalgrep, and terminalcommands. Those tools accept runid and agentid arguments from the tool caller. The underlying stores join those values into filesystem paths without rejecting absolute paths or .. traversal: Because runid can be an absolute path and agentid can contain traversal, a lower-trust prompt/user that can call these tools can read .jsonl and .log files outside the configured Dynamic Context base…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-22cj-m4wf-fv2c

  2. Revision 1 · created ·

    Published from osv record GHSA-22cj-m4wf-fv2c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56833

Advisory: PraisonAI Dynamic Context history and terminal tools read files outside configured storage via path traversal
IDs: CVE-2026-56833, GHSA-22cj-m4wf-fv2c
Record: https://patchnext.com/advisories/cve-2026-56833 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.59. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected >= 3.8.1, <= 4.6.58; fixed in 4.6.59

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-22cj-m4wf-fv2c (OSV record GHSA-22cj-m4wf-fv2c lists affected ranges: PyPI praisonai >=3.8.1 <4.6.59 (fixed))
- Verified: https://github.com/advisories/GHSA-22cj-m4wf-fv2c (GitHub-reviewed advisory GHSA-22cj-m4wf-fv2c lists affected ranges: PyPI praisonai >=3.8.1 <=4.6.58)

Commands are suggestions: review each one before running it.

Loading voting…