Skip to content

← Actionable
Medium, CVSS 6.5amended

Shopper: Negative discount values accepted and propagated through order calculation pipeline

CVE-2026-56831GHSA-5vf4-452p-jjhf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-56831: 0.43% estimated exploitation activity in the next 30 days; percentile 37.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Shopper Framework discount management functionality accepts negative discount values without server-side validation. It was confirmed that negative fixed-amount discounts can be created through the administrative interface, persisted to the database, and subsequently processed by the cart/order calculation pipeline. The application appears to assume that discount values are always positive but does not enforce this assumption during creation, storage, or calculation. As a result, malformed discount records can influence financial calculations and produce unintended order totals. --- Affected Product Package: shopper/framework Version Tested: 2.8.1 --- Vulnerability Type Business Logic Vulnerability Improper Input Validation (CWE-20) --- Description While reviewing the discount functionality, it was discovered that the application accepts negative discount values through the administrative interface. Example values tested: The application accepted these values without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5vf4-452p-jjhf

  2. Revision 1 · created ·

    Published from osv record GHSA-5vf4-452p-jjhf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56831

Advisory: Shopper: Negative discount values accepted and propagated through order calculation pipeline
IDs: CVE-2026-56831, GHSA-5vf4-452p-jjhf
Record: https://patchnext.com/advisories/cve-2026-56831 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5vf4-452p-jjhf (OSV record GHSA-5vf4-452p-jjhf lists affected ranges: Packagist shopper/framework >=0 <2.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5vf4-452p-jjhf (GitHub-reviewed advisory GHSA-5vf4-452p-jjhf lists affected ranges: Packagist shopper/framework >=0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…