Skip to content

← Actionable
Medium, CVSS 6.5amended

Shopper: Media sub-form store() still lacks authorization (Incomplete fix for GHSA-h4mp-g9c6-xwph)

CVE-2026-56830GHSA-99h5-jhh7-v3r3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-56830: 0.39% estimated exploitation activity in the next 30 days; percentile 33.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Title Missing authorization on Media sub-form store action allows unpermissioned product media update Description A lack of authorization control on the store() method was found in packages/admin/src/Livewire/Components/Products/Form/Media.php. The security fix released for GHSA-h4mp-g9c6-xwph added #[Locked] to the $product property in this file but did not add an authorize() call to store(). The commit message for that fix (fcd0c59) explicitly names the five repaired sub-form components: Edit, Inventory, Seo, Shipping, Files. Media is absent from that list and absent from the published advisory. As a result, any authenticated admin-panel session, including a staff user holding only browseproducts, can invoke store() on this component to replace the thumbnail and gallery images for any product without holding editproducts. Because $product is now #[Locked], the attacker cannot redirect the write to an arbitrary product from the client side, but the permission gate is still absent,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-99h5-jhh7-v3r3

  2. Revision 1 · created ·

    Published from osv record GHSA-99h5-jhh7-v3r3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56830

Advisory: Shopper: Media sub-form store() still lacks authorization (Incomplete fix for GHSA-h4mp-g9c6-xwph)
IDs: CVE-2026-56830, GHSA-99h5-jhh7-v3r3
Record: https://patchnext.com/advisories/cve-2026-56830 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected < 2.9.2; fixed in 2.9.2

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-99h5-jhh7-v3r3 (OSV record GHSA-99h5-jhh7-v3r3 lists affected ranges: Packagist shopper/framework >=0 <2.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-99h5-jhh7-v3r3 (GitHub-reviewed advisory GHSA-99h5-jhh7-v3r3 lists affected ranges: Packagist shopper/framework >=0 <2.9.2)

Commands are suggestions: review each one before running it.

Loading voting…