Skip to content

← Actionable
High, CVSS 8.1amended

Shopper: Unauthorized inventory stock manipulation via unlocked variant property in VariantStock component

CVE-2026-56829GHSA-g3f9-g5vj-p62f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-56829: 0.50% estimated exploitation activity in the next 30 days; percentile 43.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Title Unauthorized inventory stock manipulation via unlocked variant property in VariantStock component Description A lack of authorization control was discovered in the stockAction() method in packages/admin/src/Livewire/Components/Products/VariantStock.php. The component exposes a public $variant property without the #[Locked] attribute, so the variant ID is client-mutable via the Livewire wire payload. The stockAction() returns an Action with no -authorize(...) chain, meaning any authenticated admin-panel session, including browse-only staff who hold zero edit permissions, can call this action to adjust inventory levels for any product variant. The combination of missing authorization and an unlocked model binding lets the attacker both bypass the permission gate and redirect the mutation to an arbitrary variant in the database. Severity CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H Score: 8.1 (High) Affected files -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g3f9-g5vj-p62f

  2. Revision 1 · created ·

    Published from osv record GHSA-g3f9-g5vj-p62f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56829

Advisory: Shopper: Unauthorized inventory stock manipulation via unlocked variant property in VariantStock component
IDs: CVE-2026-56829, GHSA-g3f9-g5vj-p62f
Record: https://patchnext.com/advisories/cve-2026-56829 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected < 2.9.2; fixed in 2.9.2

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g3f9-g5vj-p62f (OSV record GHSA-g3f9-g5vj-p62f lists affected ranges: Packagist shopper/framework >=0 <2.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-g3f9-g5vj-p62f (GitHub-reviewed advisory GHSA-g3f9-g5vj-p62f lists affected ranges: Packagist shopper/framework >=0 <2.9.2)

Commands are suggestions: review each one before running it.

Loading voting…