Skip to content

← Actionable
High, CVSS 8.8amended

Shopper: privilege escalation via improper Livewire admin component authorization

CVE-2026-56828GHSA-j328-xmgp-j4q3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-56828: 0.44% estimated exploitation activity in the next 30 days; percentile 38.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Three Livewire admin components in shopper/framework (latest master at commit fcd0c59, released as v2.8.0) gate state-mutating actions on the read-only viewusers permission. This is the same class as the issue Shopper fixed in v2.8.0 / PR #511 / GHSA-f946-9qp6-vgch — the PR moved most write actions from viewusers to accesssetting, but three were missed (one of them is a brand-new file added by the security commit itself). A staff user holding only viewusers + accessdashboard (a realistic "support" or "viewer" role per Shopper's own PermissionsTableSeeder) can: (1) self-escalate by granting any permission to their own role; (2) create a brand-new admin team member with a chosen password and the admin role and then log in as that user; (3) delete arbitrary permissions rows (RBAC DoS) or — when canberemoved=true — delete entire roles. CVSS 3.1: AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H = 8.8 (High). CWE-285 (Improper Authorization) + CWE-862 (Missing Authorization). Vulnerable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j328-xmgp-j4q3

  2. Revision 1 · created ·

    Published from osv record GHSA-j328-xmgp-j4q3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56828

Advisory: Shopper: privilege escalation via improper Livewire admin component authorization
IDs: CVE-2026-56828, GHSA-j328-xmgp-j4q3
Record: https://patchnext.com/advisories/cve-2026-56828 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected >= 2.8.0, < 2.9.2; fixed in 2.9.2

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j328-xmgp-j4q3 (OSV record GHSA-j328-xmgp-j4q3 lists affected ranges: Packagist shopper/framework >=2.8.0 <2.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-j328-xmgp-j4q3 (GitHub-reviewed advisory GHSA-j328-xmgp-j4q3 lists affected ranges: Packagist shopper/framework >=2.8.0 <2.9.2)

Commands are suggestions: review each one before running it.

Loading voting…