Skip to content

← Actionable
High, CVSS 8.1amended

Shopper: Missing authorization on product removal actions in CollectionProducts component

CVE-2026-56825GHSA-2cg9-97gq-9mqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopper/framework 2.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-56825: 0.50% estimated exploitation activity in the next 30 days; percentile 43.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Title Missing authorization on product removal actions in CollectionProducts component Description A lack of authorization control was discovered on both the per-record delete action and the bulk delete action inside packages/admin/src/Livewire/Components/Collection/CollectionProducts.php. Neither the Action::make('delete') at line 73 nor the DeleteBulkAction::make() at line 91 carries an -authorize(...) chain. The component also exposes public Collection $collection without #[Locked], so the collection ID is mutable in the Livewire wire payload. Any authenticated admin-panel session, including staff who hold only browsecollections, can detach individual products or bulk-detach all products from any collection in the database. Severity CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H Score: 8.1 (High) Affected files - packages/admin/src/Livewire/Components/Collection/CollectionProducts.php:40,73-88,91-105 Steps to reproduce Prerequisites: any admin-panel account, including one whose role…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2cg9-97gq-9mqp

  2. Revision 1 · created ·

    Published from osv record GHSA-2cg9-97gq-9mqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56825

Advisory: Shopper: Missing authorization on product removal actions in CollectionProducts component
IDs: CVE-2026-56825, GHSA-2cg9-97gq-9mqp
Record: https://patchnext.com/advisories/cve-2026-56825 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopper/framework 2.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopper/framework: affected < 2.9.2; fixed in 2.9.2

## Suggested inspection (read-only)
- Packagist shopper/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopper/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2cg9-97gq-9mqp (OSV record GHSA-2cg9-97gq-9mqp lists affected ranges: Packagist shopper/framework >=0 <2.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2cg9-97gq-9mqp (GitHub-reviewed advisory GHSA-2cg9-97gq-9mqp lists affected ranges: Packagist shopper/framework >=0 <2.9.2)

Commands are suggestions: review each one before running it.

Loading voting…