Skip to content

← Actionable
High, CVSS 7.4

Netty: TOCTOU in OcspServerCertificateValidator

CVE-2026-56822GHSA-wc96-39fc-566f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler-ssl-ocsp 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-56822: 0.17% estimated exploitation activity in the next 30 days; percentile 6.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Netty's OcspServerCertificateValidator forwards the SslHandshakeCompletionEvent before the asynchronous OCSP validation completes. This allows the client's downstream handlers to send sensitive application data (e.g., HTTP requests) to a revoked server before the channel is closed by the OCSP check. Details In io.netty.handler.ssl.ocsp.OcspServerCertificateValidator#userEventTriggered, when an SslHandshakeCompletionEvent is received, the validator immediately calls ctx.fireUserEventTriggered(evt). It then initiates an asynchronous OCSP query using OcspClient.query. Because the handshake completion event is forwarded immediately, downstream handlers in the client's pipeline are notified that the TLS handshake is successful. They may then begin reading and processing incoming application data or sending outgoing data. If the OCSP response later indicates the server's certificate is REVOKED, the validator closes the channel, but by this time, the client may have already leaked…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wc96-39fc-566f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56822

Advisory: Netty: TOCTOU in OcspServerCertificateValidator
IDs: CVE-2026-56822, GHSA-wc96-39fc-566f
Record: https://patchnext.com/advisories/cve-2026-56822 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler-ssl-ocsp 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-handler-ssl-ocsp: affected >= 4.2.0.Final, < 4.2.16.Final; < 4.1.136.Final; fixed in 4.2.16.Final, 4.1.136.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-handler-ssl-ocsp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-handler-ssl-ocsp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wc96-39fc-566f (GitHub-reviewed advisory GHSA-wc96-39fc-566f lists affected ranges: Maven io.netty:netty-handler-ssl-ocsp >=4.2.0.Final =0 <4.1.136.Final)

Commands are suggestions: review each one before running it.

Loading voting…