Skip to content

← Actionable
High, CVSS 7.4

Netty: Missing CertificateID Validation in OCSP Response Allows Replay Attacks

CVE-2026-56820GHSA-272m-gcwp-mpwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler-ssl-ocsp 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-56820: 0.31% estimated exploitation activity in the next 30 days; percentile 24.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Netty's OcspClient does not validate that the CertificateID in an OCSP response matches the requested CertificateID. A bad actor can replay a GOOD status response issued for an unrelated certificate (by the same CA) to bypass revocation checks for any certificate. Details io.netty.handler.ssl.ocsp.OcspClient#validateResponse fails to assert that the CertificateID within the returned BasicOCSPResp matches the original certificate being validated. When OcspClient.query(...) executes, it builds an OCSP request using the victim certificate's serial number and issuer hash. It then sends this request and receives a response. While the client verifies the signature of the response against the trusted issuer (or a valid responder chain), it never checks the CertificateID inside the response payload. A bad actor who has access to any other valid, non-revoked certificate issued by the same CA can obtain a legitimately signed OCSP response indicating that the unrelated certificate is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-272m-gcwp-mpwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56820

Advisory: Netty: Missing CertificateID Validation in OCSP Response Allows Replay Attacks
IDs: CVE-2026-56820, GHSA-272m-gcwp-mpwg
Record: https://patchnext.com/advisories/cve-2026-56820 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler-ssl-ocsp 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-handler-ssl-ocsp: affected >= 4.2.0.Final, < 4.2.16.Final; < 4.1.136.Final; fixed in 4.2.16.Final, 4.1.136.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-handler-ssl-ocsp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-handler-ssl-ocsp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-272m-gcwp-mpwg (GitHub-reviewed advisory GHSA-272m-gcwp-mpwg lists affected ranges: Maven io.netty:netty-handler-ssl-ocsp >=4.2.0.Final =0 <4.1.136.Final)

Commands are suggestions: review each one before running it.

Loading voting…