Netty: RedisArrayAggregator max-elements failure leaves retained partial aggregate state
CVE-2026-56818GHSA-p9jm-q85p-7mcp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-redis 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-redis
- Affected
- < 4.1.136.Final>= 4.2.0-Final, < 4.2.16.Final
- Fixed in
- 4.2.16.Final, 4.1.136.Final
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p9jm-q85p-7mcp lists affected ranges: Maven io.netty:netty-codec-redis >=0 =4.2.0-Final <4.2.16.Final (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p9jm-q85p-7mcp lists affected ranges: Maven io.netty:netty-codec-redis >=0 =4.2.0-Final <4.2.16.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-56818: 0.47% estimated exploitation activity in the next 30 days; percentile 40.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary RedisArrayAggregator clears retained partial aggregate state when the maxNestedArrayDepth limit is exceeded, but it does not clear the same state when the sibling maxElements limit is exceeded. A peer can start a valid RESP array, send a bulk-string child, then send a nested array header longer than the configured maxElements. Netty throws a decoder exception, but the existing partial aggregate remains retained in the handler. If the application leaves the channel alive after the exception, later messages are still consumed into the pre-error aggregate. The supplied PoV proves both the retained ByteBuf reference and the stale parser state continuation. Technical Details RedisArrayAggregator.decode(...) retains non-array messages before adding them to depths.peek().children. In decodeRedisArrayHeader(...), the header.length() maxElements branch throws immediately: The immediately following nested-depth branch clears retained aggregate state before throwing: The missing cleanup…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p9jm-q85p-7mcp
- Revision 1 · created ·
Published from osv record GHSA-p9jm-q85p-7mcp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56818 Advisory: Netty: RedisArrayAggregator max-elements failure leaves retained partial aggregate state IDs: CVE-2026-56818, GHSA-p9jm-q85p-7mcp Record: https://patchnext.com/advisories/cve-2026-56818 (revision 2, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-redis 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-redis: affected < 4.1.136.Final; >= 4.2.0-Final, < 4.2.16.Final; fixed in 4.2.16.Final, 4.1.136.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-redis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-redis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p9jm-q85p-7mcp (OSV record GHSA-p9jm-q85p-7mcp lists affected ranges: Maven io.netty:netty-codec-redis >=0 =4.2.0-Final <4.2.16.Final (fixed)) - Verified: https://github.com/advisories/GHSA-p9jm-q85p-7mcp (GitHub-reviewed advisory GHSA-p9jm-q85p-7mcp lists affected ranges: Maven io.netty:netty-codec-redis >=0 =4.2.0-Final <4.2.16.Final) Commands are suggestions: review each one before running it.
Loading voting…