Skip to content

← Actionable
Medium, CVSS 5.3amended

n8n: Public API Execution Retry Authorization Bypass

CVE-2026-56778GHSA-h3jj-5f3v-3685

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.26.2, 2.25.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 2.26.0, < 2.26.2< 2.25.7
    Fixed in
    2.25.7, 2.26.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-56778: 0.29% estimated exploitation activity in the next 30 days; percentile 22.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Public API endpoint for retrying executions authorized access using workflow:read rather than workflow:execute. An authenticated user with read-only access to a shared workflow could use the Public API to retry executions of that workflow, bypassing the intended permission boundary between read and execute access. This issue affects instances where workflows are shared with other users or across projects. Patches The issue has been fixed in n8n versions 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow sharing to fully trusted users only. - Restrict network access to the n8n Public API to trusted users only. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h3jj-5f3v-3685

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h3jj-5f3v-3685

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56778

Advisory: n8n: Public API Execution Retry Authorization Bypass
IDs: CVE-2026-56778, GHSA-h3jj-5f3v-3685
Record: https://patchnext.com/advisories/cve-2026-56778 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.26.2, 2.25.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 2.26.0, < 2.26.2; < 2.25.7; fixed in 2.25.7, 2.26.2

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3jj-5f3v-3685 (OSV record GHSA-h3jj-5f3v-3685 lists affected ranges: npm n8n >=2.26.0 =0 <2.25.7 (fixed))
- Verified: https://github.com/advisories/GHSA-h3jj-5f3v-3685 (GitHub-reviewed advisory GHSA-h3jj-5f3v-3685 lists affected ranges: npm n8n >=2.26.0 =0 <2.25.7)

Commands are suggestions: review each one before running it.

Loading voting…