Skip to content

← Actionable
Medium, CVSS 5.3amended

n8n: Wrong OAuth Scope on Evaluation Test Runs Endpoints

CVE-2026-56775GHSA-664h-gpgq-h6xx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.26.2, 2.25.7, 1.123.55), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.55>= 2.26.0, < 2.26.2>= 2.0.0-rc.0, < 2.25.7
    Fixed in
    2.25.7, 2.26.2, 1.123.55

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2026-56775: 0.30% estimated exploitation activity in the next 30 days; percentile 23.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Three mutating endpoints in the evaluation test runs controller authorized state-changing actions using workflow:read instead of the action-appropriate workflow:execute scope. An authenticated user with project:viewer role on a project could start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only had read access to. This issue only affects instances with Advanced Permissions (Enterprise/Cloud) where projects and viewer roles are in use. Patches The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict project membership to fully trusted users only. - Avoid granting viewer access to projects containing sensitive workflows. These workarounds do not fully remediate the risk and should only be used as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-664h-gpgq-h6xx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-664h-gpgq-h6xx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56775

Advisory: n8n: Wrong OAuth Scope on Evaluation Test Runs Endpoints
IDs: CVE-2026-56775, GHSA-664h-gpgq-h6xx
Record: https://patchnext.com/advisories/cve-2026-56775 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.26.2, 2.25.7, 1.123.55. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.55; >= 2.26.0, < 2.26.2; >= 2.0.0-rc.0, < 2.25.7; fixed in 2.25.7, 2.26.2, 1.123.55

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-664h-gpgq-h6xx (OSV record GHSA-664h-gpgq-h6xx lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7 (fixed))
- Verified: https://github.com/advisories/GHSA-664h-gpgq-h6xx (GitHub-reviewed advisory GHSA-664h-gpgq-h6xx lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7)

Commands are suggestions: review each one before running it.

Loading voting…