@bsv/wallet-toolbox / -client / -mobile don't verify storage-supplied recipient output scripts against caller-requested outputs in createAction
CVE-2026-56744GHSA-36f9-7rg5-cpf8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@bsv/wallet-toolbox 2.4.0; @bsv/wallet-toolbox-client 2.4.0; @bsv/wallet-toolbox-mobile 2.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.1.47, < 2.4.0
- Fixed in
- 2.4.0
npm @bsv/wallet-toolbox-client
- Affected
- >= 1.1.47, < 2.4.0
- Fixed in
- 2.4.0
npm @bsv/wallet-toolbox-mobile
- Affected
- >= 1.3.21, < 2.4.0
- Fixed in
- 2.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-36f9-7rg5-cpf8 lists affected ranges: npm @bsv/wallet-toolbox >=1.1.47 =1.1.47 =1.3.21 <2.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-36f9-7rg5-cpf8 lists affected ranges: npm @bsv/wallet-toolbox >=1.1.47 =1.1.47 =1.3.21 <2.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-56744: 0.38% estimated exploitation activity in the next 30 days; percentile 32.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Reported by @echennells (Eric Chennells). Migrated from public issue #191 to a private advisory. Affected: @bsv/wallet-toolbox / -client / -mobile. Verified in 2.1.21 and 2.1.21-parity-fix.2; the relevant code is the same at current HEAD Summary: When createAction runs against a remote StorageClient, the storage server returns the outputs to build. buildSignableTransaction takes each non-change output's lockingScript from the storage response and signs it, without comparing it to the lockingScript the caller supplied in args.outputs. WalletPermissionsManager.createAction parses the built transaction and has args.outputs available, but uses the tx only for inputs and getFee(); it does not inspect tx.outputs. A storage provider that returns a different recipient script than requested will therefore have that script signed and broadcast, while the calling app and UI still show the originally requested recipient. Relevant code: - signer/methods/buildSignableTransaction.js — non-change…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-36f9-7rg5-cpf8
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-36f9-7rg5-cpf8
- Revision 1 · created ·
Published from ghsa record GHSA-36f9-7rg5-cpf8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56744 Advisory: `@bsv/wallet-toolbox` / `-client` / `-mobile` don't verify storage-supplied recipient output scripts against caller-requested outputs in createAction IDs: CVE-2026-56744, GHSA-36f9-7rg5-cpf8 Record: https://patchnext.com/advisories/cve-2026-56744 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @bsv/wallet-toolbox 2.4.0; @bsv/wallet-toolbox-client 2.4.0; @bsv/wallet-toolbox-mobile 2.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @bsv/wallet-toolbox: affected >= 1.1.47, < 2.4.0; fixed in 2.4.0 - npm @bsv/wallet-toolbox-client: affected >= 1.1.47, < 2.4.0; fixed in 2.4.0 - npm @bsv/wallet-toolbox-mobile: affected >= 1.3.21, < 2.4.0; fixed in 2.4.0 ## Suggested inspection (read-only) - `npm ls @bsv/wallet-toolbox --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @bsv/wallet-toolbox-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @bsv/wallet-toolbox-mobile --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @bsv/wallet-toolbox, @bsv/wallet-toolbox-client, @bsv/wallet-toolbox-mobile. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-36f9-7rg5-cpf8 (GitHub-reviewed advisory GHSA-36f9-7rg5-cpf8 lists affected ranges: npm @bsv/wallet-toolbox >=1.1.47 =1.1.47 =1.3.21 <2.4.0) - Verified: https://osv.dev/vulnerability/GHSA-36f9-7rg5-cpf8 (OSV record GHSA-36f9-7rg5-cpf8 lists affected ranges: npm @bsv/wallet-toolbox >=1.1.47 =1.1.47 =1.3.21 <2.4.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…