phpMyFAQ's two-factor authentication login bypasses the password factor
CVE-2026-56737GHSA-8gpw-xvpf-hvx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.1.6; thorsten/phpmyfaq 4.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- >= 3.2.0, < 4.1.6
- Fixed in
- 4.1.6
Packagist thorsten/phpmyfaq
- Affected
- >= 3.2.0, < 4.1.6
- Fixed in
- 4.1.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8gpw-xvpf-hvx5 lists affected ranges: Packagist thorsten/phpmyfaq >=3.2.0 =3.2.0 <4.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8gpw-xvpf-hvx5 lists affected ranges: Packagist thorsten/phpmyfaq >=3.2.0 =3.2.0 <4.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-56737: 0.53% estimated exploitation activity in the next 30 days; percentile 44.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The public two-factor verification endpoint POST /check logs a user in based solely on a valid 6-digit TOTP token and a chosen user-id. It does not require — and is not bound to — a prior successful password authentication. For any account that has 2FA enabled, an unauthenticated attacker can authenticate without knowing the password, reducing the account to a single factor (a 6-digit code) that is itself brute-forceable because this endpoint has no lockout (see Finding #2). This is an authentication bypass of the primary credential for all 2FA-protected accounts, including administrators. Details src/phpMyFAQ/Controller/Frontend/AuthenticationController.php:255-283: twoFactorSuccess() performs a complete session login (src/phpMyFAQ/User/CurrentUser.php:239-247): There is no server-side state (such as a "password already verified for this user" flag) tying the /check step to the password step. Compare the admin flow, which does it correctly via a 2fapendinguserid session…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8gpw-xvpf-hvx5
- Revision 1 · created ·
Published from osv record GHSA-8gpw-xvpf-hvx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56737 Advisory: phpMyFAQ's two-factor authentication login bypasses the password factor IDs: CVE-2026-56737, GHSA-8gpw-xvpf-hvx5 Record: https://patchnext.com/advisories/cve-2026-56737 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.1.6; thorsten/phpmyfaq 4.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected >= 3.2.0, < 4.1.6; fixed in 4.1.6 - Packagist thorsten/phpmyfaq: affected >= 3.2.0, < 4.1.6; fixed in 4.1.6 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8gpw-xvpf-hvx5 (OSV record GHSA-8gpw-xvpf-hvx5 lists affected ranges: Packagist thorsten/phpmyfaq >=3.2.0 =3.2.0 <4.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-8gpw-xvpf-hvx5 (GitHub-reviewed advisory GHSA-8gpw-xvpf-hvx5 lists affected ranges: Packagist thorsten/phpmyfaq >=3.2.0 =3.2.0 <4.1.6) Commands are suggestions: review each one before running it.
Loading voting…