phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission
CVE-2026-56736GHSA-pgwp-vc7q-cvj3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.2.0-alpha; thorsten/phpmyfaq 4.2.0-alpha), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- < 4.2.0-alpha
- Fixed in
- 4.2.0-alpha
Packagist thorsten/phpmyfaq
- Affected
- < 4.2.0-alpha
- Fixed in
- 4.2.0-alpha
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgwp-vc7q-cvj3 lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <4.2.0-alpha (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgwp-vc7q-cvj3 lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <4.2.0-alpha
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-56736: 0.24% estimated exploitation activity in the next 30 days; percentile 15.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability in phpMyFAQ allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because htmlentitydecode() converts HTML entities into executable HTML after striptags() has already passed them through, and the admin template renders the content with Twig's |raw filter without any output sanitization. Details Vulnerable file: phpmyfaq/src/phpMyFAQ/Controller/Frontend/Api/FaqController.php (lines 109-115) Root cause: Filter::filterVar() with FILTERSANITIZESPECIALCHARS internally calls filterSanitizeString() which applies striptags() to remove HTML tags. However, striptags() only removes actual HTML tag syntax (e.g., <script) — it does NOT remove HTML entities (e.g., <script>). When enableWysiwygEditorFrontend is true,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pgwp-vc7q-cvj3
- Revision 1 · created ·
Published from osv record GHSA-pgwp-vc7q-cvj3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56736 Advisory: phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission IDs: CVE-2026-56736, GHSA-pgwp-vc7q-cvj3 Record: https://patchnext.com/advisories/cve-2026-56736 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.2.0-alpha; thorsten/phpmyfaq 4.2.0-alpha. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected < 4.2.0-alpha; fixed in 4.2.0-alpha - Packagist thorsten/phpmyfaq: affected < 4.2.0-alpha; fixed in 4.2.0-alpha ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgwp-vc7q-cvj3 (OSV record GHSA-pgwp-vc7q-cvj3 lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <4.2.0-alpha (fixed)) - Verified: https://github.com/advisories/GHSA-pgwp-vc7q-cvj3 (GitHub-reviewed advisory GHSA-pgwp-vc7q-cvj3 lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <4.2.0-alpha) Commands are suggestions: review each one before running it.
Loading voting…