Skip to content

← Actionable
Medium, CVSS 5.3amended

9Router has a Login Brute-Force Lockout Bypass via Spoofable X-9r-Real-Ip Header

CVE-2026-56682GHSA-32gc-64m7-hj7v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm 9router

    Affected
    <= 0.5.4
    Fixed in
    0.5.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-56682: 0.50% estimated exploitation activity in the next 30 days; percentile 42.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary 9router enforces a progressive login lockout (5 failed attempts → temporary 30s+ lock) keyed on the client IP. The client IP used for this limiter is taken from the X-9r-Real-Ip request header, which is intended to be set only by the bundled custom-server.js layer from the unspoofable TCP socket address. In deployment modes where requests reach Next.js directly, a remote attacker controls this header and can assign a unique value to every request. Because each distinct header value maps to a fresh limiter bucket, the lockout never triggers, enabling unlimited password guessing against the dashboard login endpoint. This was reproduced against a live instance: a fixed header value was locked out (429) after 5 attempts, while rotating the header produced unlimited 401 responses with no lockout. Affected Component - src/lib/auth/loginLimiter.js - getClientIp() — derives the rate-limit bucket key from the client-supplied X-9r-Real-Ip header - checkLock() / recordFail() — per-IP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-32gc-64m7-hj7v

  2. Revision 2 · amended ·

    Amended from osv record GHSA-32gc-64m7-hj7v

  3. Revision 1 · created ·

    Published from ghsa record GHSA-32gc-64m7-hj7v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56682

Advisory: 9Router has a Login Brute-Force Lockout Bypass via Spoofable X-9r-Real-Ip Header
IDs: CVE-2026-56682, GHSA-32gc-64m7-hj7v
Record: https://patchnext.com/advisories/cve-2026-56682 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: 9router 0.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm 9router: affected <= 0.5.4; fixed in 0.5.8

## Suggested inspection (read-only)
- `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on 9router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-32gc-64m7-hj7v (GitHub-reviewed advisory GHSA-32gc-64m7-hj7v lists affected ranges: npm 9router >=0 <=0.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-32gc-64m7-hj7v (OSV record GHSA-32gc-64m7-hj7v lists affected ranges: npm 9router >=0 <0.5.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…