9Router has an Authentication Bypass in Public LLM API via Spoofable X-9r-Real-Ip Header
CVE-2026-56681GHSA-5mj8-gf6m-fhw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- <= 0.5.4
- Fixed in
- 0.5.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5mj8-gf6m-fhw8 lists affected ranges: npm 9router >=0 <=0.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5mj8-gf6m-fhw8 lists affected ranges: npm 9router >=0 <0.5.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-56681: 1.11% estimated exploitation activity in the next 30 days; percentile 66.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary 9router determines whether an incoming request originates from localhost by trusting the X-9r-Real-Ip HTTP request header. This header is intended to be produced and sanitized exclusively by the bundled custom-server.js layer from the TCP socket address. In deployment modes where requests reach Next.js directly (the header is never stripped/regenerated), a remote, unauthenticated attacker can simply send X-9r-Real-Ip: 127.0.0.1 and be treated as a local client. This bypasses the API-key requirement on the public LLM API (/api/v1/), granting unauthenticated access to the instance owner's configured provider resources. Affected Component - src/dashboardGuard.js - isLocalRequest() — trusts the client-supplied X-9r-Real-Ip header to decide loopback origin - canAccessPublicLlmApi() — grants access to /api/v1/ when isLocalRequest() returns true, skipping API-key validation - Verified affected route: GET /api/v1/models - Product version tested: 9router-app 0.5.4 (Next.js 16.2.9)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5mj8-gf6m-fhw8
- Revision 2 · amended ·
Amended from osv record GHSA-5mj8-gf6m-fhw8
- Revision 1 · created ·
Published from ghsa record GHSA-5mj8-gf6m-fhw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56681 Advisory: 9Router has an Authentication Bypass in Public LLM API via Spoofable X-9r-Real-Ip Header IDs: CVE-2026-56681, GHSA-5mj8-gf6m-fhw8 Record: https://patchnext.com/advisories/cve-2026-56681 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected <= 0.5.4; fixed in 0.5.8 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5mj8-gf6m-fhw8 (GitHub-reviewed advisory GHSA-5mj8-gf6m-fhw8 lists affected ranges: npm 9router >=0 <=0.5.4) - Verified: https://osv.dev/vulnerability/GHSA-5mj8-gf6m-fhw8 (OSV record GHSA-5mj8-gf6m-fhw8 lists affected ranges: npm 9router >=0 <0.5.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…