9router: Mass assignment in PATCH /api/settings allows authenticated authorization downgrade
CVE-2026-56679GHSA-vmjq-hvgq-2wv4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- <= 0.5.2
- Fixed in
- 0.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmjq-hvgq-2wv4 lists affected ranges: npm 9router >=0 <=0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmjq-hvgq-2wv4 lists affected ranges: npm 9router >=0 <0.5.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-56679: 0.40% estimated exploitation activity in the next 30 days; percentile 34.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The PATCH /api/settings endpoint writes the entire request body to persistent settings without a field whitelist. An authenticated user can set security-critical fields that are not meant to be modifiable here — notably requireLogin. Setting requireLogin: false disables authentication for the whole application, exposing all protected routes (e.g. /api/keys, /api/providers) to unauthenticated access. Details Root cause is unfiltered mass assignment (CWE-915): - src/app/api/settings/route.js (PATCH handler) parses the body and passes it to updateSettings(body), with special handling only for newPassword and oidcClientSecret. All other fields pass through. - src/lib/db/repos/settingsRepo.js — updateSettings does next = { ...current, ...updates }, so any key in the body overwrites stored settings, including requireLogin, tunnelDashboardAccess, authMode. - src/dashboardGuard.js — isAuthenticated returns true whenever settings.requireLogin === false, bypassing auth on all protected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-vmjq-hvgq-2wv4
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-vmjq-hvgq-2wv4
- Revision 1 · created ·
Published from ghsa record GHSA-vmjq-hvgq-2wv4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56679 Advisory: 9router: Mass assignment in PATCH /api/settings allows authenticated authorization downgrade IDs: CVE-2026-56679, GHSA-vmjq-hvgq-2wv4 Record: https://patchnext.com/advisories/cve-2026-56679 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected <= 0.5.2; fixed in 0.5.4 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vmjq-hvgq-2wv4 (GitHub-reviewed advisory GHSA-vmjq-hvgq-2wv4 lists affected ranges: npm 9router >=0 <=0.5.2) - Verified: https://osv.dev/vulnerability/GHSA-vmjq-hvgq-2wv4 (OSV record GHSA-vmjq-hvgq-2wv4 lists affected ranges: npm 9router >=0 <0.5.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…