9router: Kiro region injection allows authenticated SSRF with Authorization header forwarding
CVE-2026-56678GHSA-6mwv-4mrm-5p3m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- <= 0.5.2
- Fixed in
- 0.5.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6mwv-4mrm-5p3m lists affected ranges: npm 9router >=0 <=0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6mwv-4mrm-5p3m lists affected ranges: npm 9router >=0 <0.5.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-56678: 0.21% estimated exploitation activity in the next 30 days; percentile 11.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Kiro API-key validation endpoint builds an upstream URL using a user-controlled region value. By supplying a crafted region such as kiro-canary.local:8443#, an authenticated attacker can cause 9router to send the Kiro validation request to an attacker-controlled host under the constructed codewhisperer.<region hostname. The request forwards the submitted Kiro API key as an Authorization: Bearer header. Details - Affected version / commit: 9router v0.5.2 @ 5da508a. - Endpoint: POST /api/oauth/kiro/api-key. - Correct runtime payload: region: "kiro-canary.local:8443#". - Do not use the old @host
payload (region: "@kiro-canary.local:8443#"); it is blocked by Node/undici fetch() because it creates URL credentials ("Request cannot be constructed from a URL that includes credentials"). - Constructed upstream host becomes: codewhisperer.kiro-canary.local:8443 (the
turns the trailing .amazonaws.com into a URL fragment). - HTTPS canary captured: Authorization: Bearer…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6mwv-4mrm-5p3m
- Revision 2 · amended ·
Amended from osv record GHSA-6mwv-4mrm-5p3m
- Revision 1 · created ·
Published from ghsa record GHSA-6mwv-4mrm-5p3m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56678 Advisory: 9router: Kiro region injection allows authenticated SSRF with Authorization header forwarding IDs: CVE-2026-56678, GHSA-6mwv-4mrm-5p3m Record: https://patchnext.com/advisories/cve-2026-56678 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected <= 0.5.2; fixed in 0.5.6 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6mwv-4mrm-5p3m (GitHub-reviewed advisory GHSA-6mwv-4mrm-5p3m lists affected ranges: npm 9router >=0 <=0.5.2) - Verified: https://osv.dev/vulnerability/GHSA-6mwv-4mrm-5p3m (OSV record GHSA-6mwv-4mrm-5p3m lists affected ranges: npm 9router >=0 <0.5.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…