Skip to content

← Actionable
High, CVSS 7.5amended

elysia has Inefficient Algorithmic Complexity and Interpretation Conflict

CVE-2026-56669GHSA-9643-4qgh-g8mx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elysia 1.4.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm elysia

    Affected
    < 1.4.29
    Fixed in
    1.4.29

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-56669: 0.63% estimated exploitation activity in the next 30 days; percentile 50.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Elysia v1.4.28 is vulnerable to denial-of-service attacks due to CPU exhaustion in the form data normalization code. Elysia uses getAll to retrieve value from FormData. It is called directly relative to the total number of key-value pairs in the form data. The total amount of work the for loop has to do grows quadratically, so doubling the number of unique key-value pairs quadruples the amount of work. In the above PoC, each .getAll call scans through all of the n key-value pairs in the form data. Because there are n unique keys in the form data, there are .getAll calls, so in total the form data normalizer has to scan n x n key-value pairs. Impact Endpoints using multipart/form-data Patches 1.4.29 Workarounds no 100% confirm workaround beside updating the patch

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9643-4qgh-g8mx

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9643-4qgh-g8mx

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9643-4qgh-g8mx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56669

Advisory: elysia has Inefficient Algorithmic Complexity and Interpretation Conflict
IDs: CVE-2026-56669, GHSA-9643-4qgh-g8mx
Record: https://patchnext.com/advisories/cve-2026-56669 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elysia 1.4.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm elysia: affected < 1.4.29; fixed in 1.4.29

## Suggested inspection (read-only)
- `npm ls elysia --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elysia.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9643-4qgh-g8mx (GitHub-reviewed advisory GHSA-9643-4qgh-g8mx lists affected ranges: npm elysia >=0 <1.4.29)
- Verified: https://osv.dev/vulnerability/GHSA-9643-4qgh-g8mx (OSV record GHSA-9643-4qgh-g8mx lists affected ranges: npm elysia >=0 <1.4.29 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…