Skip to content

← Actionable
Medium, CVSS 4.2amended

ZITADEL: Missing Token Expiration (exp) Validation in JWT IdP Provider

CVE-2026-56665GHSA-v77h-2w3m-94hx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/zitadel/zitadel 4.15.2, 3.4.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-56665: 0.27% estimated exploitation activity in the next 30 days; percentile 18.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A token lifecycle validation vulnerability was discovered in ZITADEL's external JWT Identity Provider (IdP) implementation Specifically, within the validation pipeline, if an incoming JWT omits the exp claim entirely, the expiration block is silently skipped rather than rejected. The token is treated as valid forever. Per the OIDC Core 1.0 specification, identity token validation pipelines must strictly handle and enforce session expiration. ZITADEL's silent acceptance of tokens missing these temporal constraints compromises session integrity. Impact An attacker in possession of a token lacking an exp claim holds a permanent credential with no automatic expiration or revocation window. Affected Versions Systems running one of the following versions are affected: 4.x: 4.0.0 through 4.15.1 (including RC versions) 3.x: 3.0.0 through 3.4.11 (including RC versions) Patches The vulnerability has been addressed in the latest releases. ZITADEL now explicitly rejects tokens that lack…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v77h-2w3m-94hx

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6469

  3. Revision 1 · created ·

    Published from osv record GHSA-v77h-2w3m-94hx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56665

Advisory: ZITADEL: Missing Token Expiration (`exp`) Validation in JWT IdP Provider
IDs: CVE-2026-56665, GHSA-v77h-2w3m-94hx
Record: https://patchnext.com/advisories/cve-2026-56665 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/zitadel/zitadel 4.15.2, 3.4.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/zitadel/zitadel: affected >= 4.0.0-rc.1, < 4.15.2; < 3.4.12; fixed in 3.4.12, 4.15.2

## Suggested inspection (read-only)
- Go github.com/zitadel/zitadel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/zitadel/zitadel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v77h-2w3m-94hx (OSV record GHSA-v77h-2w3m-94hx lists affected ranges: Go github.com/zitadel/zitadel >=4.0.0-rc.1 =0 <3.4.12 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6469 (OSV record GO-2026-6469 lists affected ranges: Go github.com/zitadel/zitadel >=0)
- Verified: https://github.com/advisories/GHSA-v77h-2w3m-94hx (GitHub-reviewed advisory GHSA-v77h-2w3m-94hx lists affected ranges: Go github.com/zitadel/zitadel >=4.0.0-rc.1 =0 <3.4.12)

Commands are suggestions: review each one before running it.

Loading voting…